ViPR SRM: VNX File Quotas Not Reporting Data

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Symptoms



The ViPR SRM "File Components/Quotas" report is blank and states "This report does not select any data."

It has been verified that the tree quotas have been set-up on the array(s) in question.  No errors were found in the VNX collector logs or LBC logs on the VNX collector host collecting for the array(s) in questions pertaining to quotas.  There was no reference to quotas as all in the logs.

The following command was run on the ViPR SRM VNX collector host for the array(s) in question from the following path:

/opt/APG/Collecting/Stream-Collector/emc-vnx/conf/requests:  ./request sh -f <IP of ControlStation> -u XXXX -p XXXX -r vnxfile-quota.xml

The following output was returned by the command in the response.xml in the /opt/APG/Collecting/Stream-Collector/emc-vnx/conf/requests directory:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ResponsePacket xmlns="http://www.emc.com/schemas/celerra/xml_api">
 <PacketFault maxSeverity="error">
 <Problem messageCode="14227144705" facility="Generic" component="API" message="Unexpected exception of unknown nature." severity="error">
 <Description>The XML API server took an unexpected exception. This does not mean that it stopped functioning for other users. (In most casses it is an APL reply unmarshalling error).</Description>
 <Action>If the problem persists, collect support materials by running the /nas/tools/collect_support_materials script or the newer /nas/tools/automaticcollection script. Note any symptoms. If you require more information on the materials collection process, refer to the Problem Resolution Roadmap for Celerra, available on EMC Powerlink, or EMC Knowledgebase Support Solution number emc135846.

 For more information, use the text from the error message's brief description or the message's ID to search the Knowledgebase on Powerlink. After logging in to Powerlink, go to Support &gt; Knowledgebase Search &gt; Support Solutions Search.</Action>
 <Diagnostics>
Exception tag: 15cc1720d5e
Exception message: Java heap space
</Diagnostics>
 </Problem>
 </PacketFault>
</ResponsePacket>
 

Cause

The VNX backend array does not have enough Java heap memory allocated on the ControlStation for the request to complete.  The default Java heap memory setting is 180 MB.

Resolution

Increase the Java heap memory allocated on the VNX backend array's ControlStation to 256 MB initially.  If the Java heap space exception is still encountered, increase the Java heap memory to 512 MB. If help is needed increasing Java Heap. please open a ticket with the VNX group.

Affected Products

Entry Level & Midrange, Storage Software
Article Properties
Article Number: 000064529
Article Type: Solution
Last Modified: 31 Jan 2025
Version:  4
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