RecoverPoint/SRM: Operacje przełączania awaryjnego lub testowania trybu failover kończą się niepowodzeniem z błędami nie znaleziono woluminu/VMFS

Summary: Przełączanie awaryjne lub testowe przełączanie awaryjne Site Recovery Manager (SRM) kończy się niepowodzeniem z powodu błędów "Nie można odnaleźć woluminu VMFS dla magazynu danych" lub podobnego Nie znaleziono woluminu/VMFS. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Spróbuj przełączyć się w tryb failover lub uruchomić test trybu failover programu Site Recovery Manager (SRM).

Przełączanie awaryjne SRM lub testowe przełączanie awaryjne kończy się niepowodzeniem, ponieważ nie znaleziono woluminów/VMFS.

Przykładowe błędy w dziennikach SRM:
 
2017-05-21T14:20:53.757+03:00 [53540 error 'AbrRecoveryEngine' opID=773f5494:dd26:ffe2] Dr::Providers::Abr::AbrRecoveryEngine::RecoverVmfsDatastore: Cannot find VMFS volume for datastore 'ds:///vmfs/volumes/57c9acfd-5ead583e-ada6-0017a477xxxx/': (dr.storageProvider.VmfsRecoverySpec) {


2017-05-21T14:20:53.761+03:00 [193968 verbose 'AbrRecoveryEngine' opID=773f5494:dd26:ffe2] FailDeviceGroups: Failing group
2017-05-21T14:20:53.761+03:00 [193968 verbose 'AbrRecoveryEngine' opID=773f5494:dd26:ffe2] GroupCallbackHandler::FailGroup: Failing group 'vm-protection-group-xxxxxx'
2017-05-21T14:20:53.761+03:00 [193968 verbose 'Replication' opID=773f5494:dd26:ffe2] Dr::Replication::EntityOperationJoinerBase<class Dr::TypedMoRef<class Dr::Replication::ProtectionGroup,void>,void>::EntityFailed: Received a failure update for protection group Id=[dr.replication.VmProtectionGroup:bcf4f9b1-2063-4d9a-b773-93be06xxxxxx:vm-protection-group-xxxxxx], error=
--> (dr.storageProvider.fault.DatastoreRecoveryFailed) {
-->    faultCause = (dr.storageProvider.fault.RecoveryVmfsVolumeNotFound) {
-->       faultCause = (dr.storageProvider.fault.RecoveryDeviceNotFound) {
-->          faultCause = (vmodl.MethodFault) null, 
-->          device = "60:06:01:60:0C:F0:3D:00:0E:29:21:28:xx:xx:xx:xx", 
-->          msg = ""
-->       }, 
-->       device = (string) [
-->          "60:06:01:60:0C:F0:3D:00:0E:29:21:28:x:xx:xx:x"
-->       ], 
-->       msg = ""
-->    }, 
-->    protectedName = "General", 
-->    protectedUrl = "ds:///vmfs/volumes/57c9acfd-5ead583e-ada6-0017a4770xxx/", 
-->    msg = ""
--> }



Wygląda na to, że ręczne montowanie urządzeń docelowych bez SRM działa.

Cause

W niektórych scenariuszach czas potrzebny do wyświetlenia urządzeń w węzłach ESXi jest dłuższy niż domyślny limit czasu.
Ten problem wymaga drugiego skanowania lub opóźnienia przed skanowaniem.

Resolution

Rozwiązanie:

Zmiana parametrów ESXi/SRM wykrywania pamięci masowej.
Można je zmienić na różne liczby, w zależności od środowiska. Większe środowiska z większą liczbą jednostek LUN lub hostów ESXi mogą wymagać dłuższych limitów czasu, ponownych prób lub opóźnień.

  1. Otwórz klienta vSphere Web Client.
  2. Kliknij prawym przyciskiem myszy witrynę SRM, którą chcesz zmodyfikować, i wybierz opcję Ustawienia zaawansowane.
  3. Kliknij opcję StorageProvider.
  4. Sprawdź/edytuj parametry:
    • storageProvider.hostRescanDelaySec — wartość domyślna to 0, spróbuj zmienić na liczbę z zakresu od 20 do 180
    • storageProvider.hostRescanRepeatCnt — wartość domyślna to 1, spróbuj zmienić na liczbę z zakresu od 2 do 3
    • storage.commandTimeout — wartość domyślna to 300, próba zwiększenia do 600 lub 900

Podobne informacje można znaleźć w artykułach firmy Broadcom, na przykład KB 383166.

Affected Products

RecoverPoint, RecoverPoint CL, RecoverPoint EX

Products

RecoverPoint SE
Article Properties
Article Number: 000065070
Article Type: Solution
Last Modified: 09 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.