DPA:未使用本機系統帳戶時,代理程式無法啟動

Summary: 使用指定的 Windows 帳戶而非本機系統帳戶時,Data Protection Advisor (DPA) 代理程式無法啟動;缺少「作為服務登入」權限和資料夾權限,會導致登入失敗。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



嘗試透過已設定為使用命名帳戶而非本機系統帳戶進行 Windows 驗證的 DPA 代理程式從 Microsoft SQL Server 收集時,出現下列問題:
  • DPA 代理程式無法開始,因登入失敗而無法啟動
  • 未更新 dpaagent 記錄和 agent\data 資料夾下的檔案

Cause

用於 DPA 代理程式的命名帳戶未設定所有必要的權限 

Resolution

用於 DPA 代理程式的命名帳戶需要額外權限才能正確執行:
  1. 向指定帳戶授予「作為服務登錄」特權
  2. 更新代理安裝資料夾的許可權以授予命名帳戶完全控制
如需更多詳細資料或資訊,請聯絡 Dell EMC 技術支援部門。

Affected Products

App Direct File System Agent
Article Properties
Article Number: 000071464
Article Type: Solution
Last Modified: 10 Dec 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.