Avamar: 데이터 상태가 나타나지 않고 백업 실패 - 플러그인 버전을 확인할 수 없음

Summary: "No Data" 상태로 백업 실패 - Avagent가 "플러그인 버전을 확인할 수 없음"을 보고합니다.

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Symptoms

예약된 백업 또는 Policy 창에서 시작된 백업은 "No Data" 상태로 즉시 실패합니다.

작업 모니터에 데이터가 표시되지 않는 오류를 보여주는 이미지 

  • 상태를 마우스로 가리키면 "Activity Failed - client has no data specified by dataset"가 표시됩니다.

    작업 모니터에 데이터가 표시되지 않는 오류를 보여주는 이미지 
  • "Activity Report" 탭에는 다음과 같이 표시됩니다.

    상태 코드 30915를 보여주는 이미지   데이터 세트에 데이터가 없어 작업이 실패했음을 보여주는 이미지 
    • Status_code "30915" 및 status_code_summary "Activity failed - client has no data specified by dataset"
  • "Activities - Failed" 보고서에는 다음과 같이 표시됩니다.

    보고서 실행 시 데이터가 없어 30915 작업이 실패했음을 보여주는 이미지 
    • 상태 "30915: 작업 실패 - 클라이언트에 데이터 세트로 지정된 데이터가 없습니다."

Cause

이 오류는 여러 가지 원인으로 인해 발생할 수 있습니다.

  • 아래에 나열되지 않은 오류의 경우 해결 경로에서 추가 원인 및 해결 방법을 참조하십시오.
  • AVE 또는 단일 노드가 Data Domain으로만 백업을 가리키도록 잠겨 있는 경우 이는 예상된 동작입니다.
    • Avamar-Data Domain 통합: 단일 노드의 Data Domain 백엔드에 대한 모든 Avamar 및 Avamar Virtual Edition 백업을 잠그는 방법
      • Server 열에 DD-server-name이 표시되어야 합니다.
        작업 모니터에 데이터가 표시되지 않는 오류를 보여주는 이미지 
      • 백업, 복원 및 관리 창의 백업 탭을 사용하여 클라이언트 액세스 가능성을 확인합니다.

        찾아보기를 사용한 연결 확인을 보여주는 이미지 
        • 플러그인이 표시되고 탐색 가능한 경우 해결 경로를 참조하십시오.
      • 플러그인이 표시되지 않고 "이 클라이언트의 구성이 검색을 지원하지 않습니다" 또는 "xxxxx 클라이언트에 대한 플러그인을 찾을 수 없습니다"라는 창이 나타나는 경우. 그런 다음 클라이언트 시스템의 avagent.log 검사해야 합니다.

        클라이언트 플러그인이 감지되지 않고 탐색이 실패하는 경우의 실패를 보여주는 이미지  

        클라이언트 플러그인이 감지되지 않을 때의 실패를 보여주는 이미지 
        • avagent.log는 기본적으로 C:\Program Files\avs\var에 있습니다.
      • Avamar Grid의 MCS(Management Console Server) 또는 클라이언트 머신 자체에서 플러그인을 비활성화하고 있습니다.
        • MCS가 플러그인을 비활성화하는 경우 해결 경로에서 적절한 해결 방법을 참조하십시오.
        • 클라이언트 시스템 자체에서 플러그인을 비활성화하면 로그에 다음과 같은 오류가 기록됩니다.
avagent Error <5451>: Failed to get plugin 'Windows' version with code 0xc0000142: No error description string
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled
  • 또는
 
avagent Error <5451>: Failed to get plugin 'Windows' version with code 128: There are no child processes to wait for 
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin 
avagent Error <5937>: Plugin Windows disabled 
  • 또는
     
avagent Error <5451>: Failed to get plugin 'Windows' version with code 255: The extended attributes are inconsistent
avagent Error <5924>: Unable to determine plugin version for Windows pin file C:\Program Files\avs\bin\windows.pin
avagent Error <5937>: Plugin Windows disabled


이러한 오류는 시스템에 설치된 모든 플러그인, 즉 'Windows VSS', 업데이트, SQL 등에 대해 반복됩니다.

로그 보고서(설치된 Avamar Client 버전에 따라 다름):

avagent Warning <7145>: No pin files found

 

  • 또는
     
avagent Warning <7184>: No pin files found

 

Windows 이벤트 뷰어에서 시스템 로그를 열고 다음과 같은 이벤트 ID 243을 찾습니다.
 
Log Name:      System
Source:        Win32k
Date:          4/24/2014 10:54:54 AM
Event ID:      243
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      Workstation.emc.com
Description:
A desktop heap allocation failed.


데스크탑 힙은 로컬 시스템 계정을 사용하는 모든 애플리케이션에 대한 공유 메모리 스토리지 공간입니다. 이벤트 뷰어의 시스템 로그에 "데스크탑 힙 할당" 오류 메시지가 표시되는 경우 메모리 누수로 인한 것일 수 있습니다. 클라이언트의 애플리케이션은 RAM 사용률이 낮더라도 데스크톱 힙에 할당된 모든 메모리를 사용하여 이 문제를 일으킬 수 있습니다.

이 경우 재부팅할 때까지 백업이 계속 실패하고 동일한 오류가 발생합니다. 재부팅 후 백업이 며칠 동안 다시 작동한 후 다시 실패하기 시작합니다. 다시 재부팅하면 며칠 더 문제가 해결됩니다.
 

참고:  초기 클라이언트 활성화 중에 플러그인이 등록되지 않으면 바이러스 백신 소프트웨어로 인해 이 문제가 발생할 수도 있습니다.
Symantec과 같은 일부 안티바이러스 소프트웨어는 매우 안전하고 엄격한 검사 설정으로 구성될 수 있으며, 이로 인해 avtar 및 데이터베이스 플러그인이 등록되지 않을 수 있습니다.
바이러스 백신 소프트웨어에서 avtar.exe 및 avagent.exe 프로세스를 제외하더라도 Avamar Client 설치 및 등록이 작동하지 않을 수 있습니다.

Resolution

AVE 또는 단일 노드가 백업을 Data Domain으로만 가리키도록 잠긴 경우 적절한 Data Domain으로 백업을 지정하도록 데이터 세트를 조정합니다.

안티바이러스로 인해 플러그인이 등록되지 않는 경우: 바이러스 백신 소프트웨어를 일시적으로 비활성화하고 실행 중인 기존 바이러스 백신 프로세스를 모두 종료합니다. 그런 다음 Avamar Client MSI 패키지를 정상적으로 다시 설치합니다.

데스크탑 힙 할당 실패로 인해 플러그인이 비활성화된 경우 옵션은 다음과 같습니다.

  1. 메모리 누수가 발생할 수 있는 애플리케이션/프로그램을 비활성화하거나 제거합니다. 문제가 되는 프로그램을 찾기 위해 Microsoft 지원과 협력합니다. 또는 예약된 일정에 따라 컴퓨터를 다시 부팅하면 데스크톱 힙이 일시적으로 플러시됩니다.
  2. 레지스트리에서 최대 힙 값을 늘리고 Windows 클라이언트를 재부팅하여 변경 내용을 적용합니다. 절차 및 권장 값은 다음 URL을 사용하십시오.
  3. 문제가 되는 애플리케이션을 식별할 수 없거나 애플리케이션을 식별하는 동안 선호하는 장기 해결 방법.
    • Avamar "Backup Agent" 서비스를 기본 NT Authority\SYSTEM 계정에서 Windows 클라이언트에 대한 충분한 사용 권한이 있는 도메인 사용자 계정으로 변경하고 서비스를 재시작하여 변경 사항을 적용합니다. 백업 에이전트 서비스는 기본적으로 SYSTEM 계정으로 실행되지만 Windows 클라이언트에서는 적어도 R/W 액세스 권한이 있는 모든 NT 도메인 계정을 사용할 수 있습니다. 이는 Avamar 서비스가 더 이상 System으로 로그인된 다른 프로그램(메모리 누수가 있는 프로그램 포함)과 동일한 힙을 사용하지 않기 때문입니다.
    • 아래 URL은 이 해결 방법 및 기타 해결 방법에 대한 몇 가지 세부 정보를 제공합니다.

Affected Products

Avamar Client, Avamar Plug-in
Article Properties
Article Number: 000159530
Article Type: Solution
Last Modified: 19 Nov 2025
Version:  7
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