SRM 4.5: 데이터베이스 관리 메트릭에서 디바이스를 삭제하는 동안 오류 발생

Summary: 데이터베이스 관리 메트릭에서 비활성 디바이스를 삭제한 후, 메시지는 성공을 나타내지만 MySQL을 사용할 때 계속 삭제된 비활성 디바이스가 표시됩니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

사용자가 데이터베이스 관리 메트릭에서 비활성 디바이스의 데이터를 쿼리할 수 있습니다. 클릭하여 삭제할 경우 삭제 메시지에 오류 없이 성공 메시지가 표시됩니다. 사용자가 MySQL에서 동일한 디바이스를 쿼리하자 메트릭 수가 여전히 표시되고 값이 삭제되지 않았습니다.

Frontend Catalina 로그를 확인하여 아래의 오류를 찾았습니다.     
Feb 23, 2021 4:23:57 PM com.watch4net.apg.v2.modules.admin.VariableManagementDeleteCallback error
SEVERE: Error when deleting.
com.sun.xml.internal.ws.fault.ServerSOAPFaultException: Client received SOAP Fault from server: javax.xml.bind.UnmarshalException
with linked exception:
[javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1,1500581]
Message: An invalid XML character (Unicode: 0xc) was found in the element content of the document.] Please see the server log to find more detail regarding exact cause of the failure.
at com.sun.xml.internal.ws.fault.SOAP11Fault.getProtocolException(SOAP11Fault.java:178)
at com.sun.xml.internal.ws.fault.SOAPFaultBuilder.createException(SOAPFaultBuilder.java:116)
at com.sun.xml.internal.ws.client.sei.StubHandler.readResponse(StubHandler.java:238)
at com.sun.xml.internal.ws.db.DatabindingImpl.deserializeResponse(DatabindingImpl.java:189)
at com.sun.xml.internal.ws.db.DatabindingImpl.deserializeResponse(DatabindingImpl.java:276)
at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:104)
at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:77)
at com.sun.xml.internal.ws.client.sei.SEIStub.invoke(SEIStub.java:147)
at com.sun.proxy.$Proxy212.deleteVariables(Unknown Source)
at com.watch4net.apg.v2.modules.admin.WebServiceCommunication.deleteVariables(WebServiceCommunication.java:250)
at com.watch4net.apg.v2.modules.admin.VariableManagement$VariableDeleterThread.run(VariableManagement.java:342)

Cause

Tomcat 서비스 및 WebService 게이트웨이가 완전히 업그레이드되지 않았을 수 있습니다.

Resolution

프런트엔드 서버에 로그인하고 다음 명령을 실행합니다.     

  • /opt/APG/bin/manage-modules.sh service update tomcat Default
  • /opt/APG/bin/manage-modules.sh service start tomcat Default
  • /opt/APG/bin/manage-modules.sh service update webservice-gateway Default
  • /opt/APG/bin/manage-modules.sh service start webservice-gateway Default

Products

SRM, SRM
Article Properties
Article Number: 000184238
Article Type: Solution
Last Modified: 29 Aug 2022
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.