Data Protection Advisor (DPA): La richiesta di data collection PPDM ha esito negativo con funzione rilevata InvalidStatusException

Summary: La richiesta di data collection PPDM ha esito negativo con funzione di messaggio rilevata InvalidStatusException

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La sezione History della richiesta di raccolta dati PPDM Job Monitor presenta il seguente messaggio di stato:
Function jobmonitor caught ProcessingException

Lo stesso messaggio viene visualizzato nel dpaagent.log dopo aver richiesto una risposta API dal server PPDM:
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute(): function jobmonitor ha intercettato InvalidStatusException

Cause

La richiesta API prima dell'ERR non ha risposto con lo stato previsto.
La dpaagent.log debug bassa mostra la richiesta API che ha generato l'eccezione:

DBG1 12669.12677 20210211:071704 com.emc.dpa.agent.co - get(): GET [/api/v2/assets?pageSize=5000&page=1]
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute(): function jobmonitor ha intercettato InvalidStatusException


Utilizzando un client REST, la richiesta /api/v2/assets?pageSize=5000 generava il seguente messaggio dal server PPDM dopo 60 sec:

{ "reason" : "Gateway Timeout Error.", "remediation" : "Riprova l'operazione più tardi.", "codice" : 504, "sentiero" : "/api/v2/assets", "timestamp": 1613473517745 }

L'errore di timeout del gateway proviene da PPDM dopo 60 secondi, indipendentemente dai timeout impostati nella richiesta DPA.
La richiesta API /api/v2/assets?pageSize=100 restituisce correttamente le informazioni dallo stesso server PPDM.

Resolution

DPA funziona come previsto.
Il server PPDM restituisce uno stato imprevisto per la richiesta API a causa di un problema di prestazioni.
Questo problema deve essere analizzato dal lato PPDM.

Per ulteriori informazioni, contattare il supporto tecnico Dell.

Products

Data Protection Advisor
Article Properties
Article Number: 000184325
Article Type: Solution
Last Modified: 12 Nov 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.