Data Protection Advisor (DPA): Forespørsel om PPDM-datainnsamling mislykkes med funksjonen registrert InvalidStatusException

Summary: Forespørsel om PPDM-datainnsamling mislykkes med meldingsfunksjonen fanget InvalidStatusException

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Historikk-delen av PPDM Job Monitor-datainnsamlingsforespørselen har følgende statusmelding:
Funksjon jobmonitor fanget ProcessingException

Den samme meldingen vises i dpaagent.log etter å ha bedt om et API-svar fra PPDM-serveren:
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute(): Funksjon jobmonitor fanget InvalidStatusException

Cause

API-forespørselen før feilen svarte ikke med en forventet status.
Den lave feilsøkingen dpaagent.log viser API-forespørselen som genererte unntaket:

DBG1 12669.12677 20210211:071704 com.emc.dpa.agent.co - get(): GET [/api/v2/assets?pageSize=5000&page=1]
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute(): Funksjon jobmonitor fanget InvalidStatusException


Ved hjelp av en restklient genererte forespørselen /api/v2/assets?pageSize=5000 følgende melding fra PPDM-serveren etter 60sec:

{ "reason": "Gateway Timeout Error.", "remediation" : "Prøv operasjonen på nytt senere.", "kode" : 504, "bane": "/api/v2/assets", "timestamp" : 1613473517745 }

Gateway Timeout Error kommer fra PPDM etter 60 sekunder, uavhengig av tidsavbruddene vi har angitt for DPA-forespørselen.
API-forespørselen /api/v2/assets?pageSize=100 returnerer informasjon fra den samme PPDM-serveren.

Resolution

DPA fungerer som den skal.
PPDM-serveren returnerer en uventet status for API-forespørselen på grunn av et ytelsesproblem.
Dette problemet må undersøkes fra PPDM-siden.

Hvis du vil ha mer informasjon, kan du kontakte Dells tekniske kundestøtte.

Products

Data Protection Advisor
Article Properties
Article Number: 000184325
Article Type: Solution
Last Modified: 12 Nov 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.