FuenteUno: La ventana de restauración de búsqueda web no muestra carpetas de buzones de correo en el segundo intento después de mostrar inicialmente la lista de carpetas para su selección
Summary: La ventana de restauración del buscador web de SourceOne Web no puede cargar la lista de carpetas debido a errores de tiempo de espera agotado.
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Symptoms
Si un usuario utiliza el buscador web de SourceOne y selecciona el botón “Restore” para restaurar los mensajes seleccionados a una carpeta de buzón de correo de Microsoft Exchange, en la ventana de restauración del intento inicial se mostrará la lista de carpetas, los intentos posteriores de seleccionar el botón “Restore” no podrán cargar las carpetas de buzones de correo de forma correcta en la ventana de restauración.
A continuación, se muestra un ejemplo de cómo se vería la ventana de restauración:
Si se utilizarán herramientas para desarrolladores dentro de los navegadores, se pueden encontrar mensajes de error similares a los siguientes:
A continuación, se muestra un ejemplo de cómo se vería la ventana de restauración:
Si se utilizarán herramientas para desarrolladores dentro de los navegadores, se pueden encontrar mensajes de error similares a los siguientes:
Navigated to http://localhost/SEARCH/Restore.aspx favicon.ico:1 GET http://localhost/favicon.ico 404 (Not Found) ScriptResource.axd?d=78G0Omd0Kv__hpA1m1w13E5yK4XDO9aHSxVcfebeXUMF-eee66VovRG1HcTLFM-bbG2N5Qmv2-XjKMXO-f65ZVHBtcrp4C7DzelHUZZ7c61HePGWecVri7pk-kkp-Xrf1ytMoxWrcOO58uHi-vqbBXBkr1-hHhCRsBNTkUZZMWCfzXRQLmDkvvRCH-thmuva0&t=ffffffffecf19baa:5 Uncaught Sys.WebForms.PageRequestManagerTimeoutException: Sys.WebForms.PageRequestManagerTimeoutException: The server request timed out.
Cause
Este problema se debe a una fallo de software mencionada en SDR 63291.
Mientras se intenta obtener una lista de carpetas que se muestra en intentos posteriores, en algunos entornos, el tiempo necesario para obtener una respuesta completa a las llamadas programáticas puede tardar más que el límite codificado de forma rígida de 90 segundos establecido en el archivo Restore.aspx.
Mientras se intenta obtener una lista de carpetas que se muestra en intentos posteriores, en algunos entornos, el tiempo necesario para obtener una respuesta completa a las llamadas programáticas puede tardar más que el límite codificado de forma rígida de 90 segundos establecido en el archivo Restore.aspx.
Resolution
Este problema se resolverá en los parches o en las versiones de Service Pack de Dell EMC SourceOne Email Management posteriores a 7.2.SP10 HF3 (7.2.10.0076). Los kits de Dell EMC SourceOne Patch y Service Pack están disponibles para su descarga mediante https://support.dell.com.
Hay un hot fix disponible para los clientes que ejecutan EMC SourceOne Email Management 7.2.SP9 y 7.2.SP10. Comuníquese con el soporte técnico de EMC, comparta el artículo de la nota de soporte y el número de SDR (63291) con su representante de soporte.
Cada sitio puede tener diferentes razones para que las llamadas programáticas tarden más tiempo. Se pueden seguir los siguientes pasos para aumentar el tiempo de espera, lo que permite que se muestre la lista de carpetas para su selección en caso de que no se pueda identificar la causa raíz del retraso:
Después de realizar el cambio, guarde y cierre el archivo web.config.
Nota: El valor es en milisegundos. El valor establecido en 180 000 permite un tiempo de espera de 180 segundos. Se puede cambiar en función de los entornos del cliente, por ejemplo, para establecer un ajuste de tiempo de espera agotado de 2 minutos será 120 000.
Hay un hot fix disponible para los clientes que ejecutan EMC SourceOne Email Management 7.2.SP9 y 7.2.SP10. Comuníquese con el soporte técnico de EMC, comparta el artículo de la nota de soporte y el número de SDR (63291) con su representante de soporte.
Cada sitio puede tener diferentes razones para que las llamadas programáticas tarden más tiempo. Se pueden seguir los siguientes pasos para aumentar el tiempo de espera, lo que permite que se muestre la lista de carpetas para su selección en caso de que no se pueda identificar la causa raíz del retraso:
- Obtenga el archivo de biblioteca del equipo de soporte de Dell EMC o asegúrese de estar en la versión de SourceOne Email Management que contiene la corrección. Si obtuvo el archivo de biblioteca del equipo de soporte de Dell EMC, realice un respaldo del binario existente e instale el nuevo binario que se le proporcionó en la carpeta de instalación del buscador web de SourceOne que contiene el archivo de biblioteca, por ejemplo, “E:\Program Files (x86)\EMC SourceOne\Search\WebApp\bin”.
- Vaya al directorio de instalación del buscador web SourceOne Web Search que contiene el archivo web.config, por ejemplo, “E:\Program Files (x86)\EMC SourceOne\Search\WebApp”.
- Haga una copia del archivo web.config y guárdelo en otra ubicación como respaldo del archivo de configuración original.
- Edite el archivo web.config y, en la <sección appSettings></appSettings,> agregue la siguiente línea:
<add key="SearchWebServiceTimeoutSeconds" value="180000" />
Después de realizar el cambio, guarde y cierre el archivo web.config.
Nota: El valor es en milisegundos. El valor establecido en 180 000 permite un tiempo de espera de 180 segundos. Se puede cambiar en función de los entornos del cliente, por ejemplo, para establecer un ajuste de tiempo de espera agotado de 2 minutos será 120 000.
- Inicie sesión en el buscador web de SourceOne y pruebe la operación de restauración.
Additional Information
El problema se encontraría en los servidores de búsqueda web de SourceOne donde está instalado Microsoft Outlook 2013, 2016 o 2019. En los servidores de búsqueda web de SourceOne, si Outlook 2010 SP2 está instalado, se resuelve el problema. Las actualizaciones más recientes para Microsoft Outlook versión 2013, 2016 o 2019, en el momento de escribir este artículo de la base de conocimientos (3 de mayo del 2021) no resuelven el problema.
Affected Products
SourceOne, SourceOne, SourceOne Archiving, SourceOne Email ManagementArticle Properties
Article Number: 000186076
Article Type: Solution
Last Modified: 02 Sept 2025
Version: 9
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