SourceOne: la finestra Restore di Web Search non visualizza le cartelle della casella postale al secondo tentativo, dopo aver inizialmente visualizzato l'elenco delle cartelle da selezionare
Summary: La finestra Restore di SourceOne Web Search non riesce a caricare l'elenco di cartelle a causa di errori di timeout.
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Symptoms
Se un utente utilizza SourceOne Web Search e seleziona il pulsante "Restore" per effettuare il restore di messaggi selezionati in una cartella della casella postale Microsoft Exchange, nella finestra del tentativo iniziale di restore viene visualizzato l'elenco delle cartelle, ma i tentativi successivi di selezionare il pulsante "Restore" non caricano correttamente le cartelle della casella postale nella finestra Restore.
Di seguito è riportato un esempio dell'aspetto della finestra Restore:
Se vengono utilizzati strumenti di sviluppo all'interno dei browser, potrebbero essere visualizzati messaggi di errore simili a quelli riportati di seguito:
Di seguito è riportato un esempio dell'aspetto della finestra Restore:
Se vengono utilizzati strumenti di sviluppo all'interno dei browser, potrebbero essere visualizzati messaggi di errore simili a quelli riportati di seguito:
Navigated to http://localhost/SEARCH/Restore.aspx favicon.ico:1 GET http://localhost/favicon.ico 404 (Not Found) ScriptResource.axd?d=78G0Omd0Kv__hpA1m1w13E5yK4XDO9aHSxVcfebeXUMF-eee66VovRG1HcTLFM-bbG2N5Qmv2-XjKMXO-f65ZVHBtcrp4C7DzelHUZZ7c61HePGWecVri7pk-kkp-Xrf1ytMoxWrcOO58uHi-vqbBXBkr1-hHhCRsBNTkUZZMWCfzXRQLmDkvvRCH-thmuva0&t=ffffffffecf19baa:5 Uncaught Sys.WebForms.PageRequestManagerTimeoutException: Sys.WebForms.PageRequestManagerTimeoutException: The server request timed out.
Cause
Il problema è causato dal difetto software citato in SDR 63291.
Durante il tentativo di visualizzare l'elenco delle cartelle nei tentativi successivi, in alcuni ambienti il tempo necessario per ottenere una risposta completa alle chiamate a livello di codice potrebbe richiedere più tempo rispetto al limite hardcoded di 90 secondi impostato all'interno del file Restore.aspx.
Durante il tentativo di visualizzare l'elenco delle cartelle nei tentativi successivi, in alcuni ambienti il tempo necessario per ottenere una risposta completa alle chiamate a livello di codice potrebbe richiedere più tempo rispetto al limite hardcoded di 90 secondi impostato all'interno del file Restore.aspx.
Resolution
Questo problema verrà risolto nelle patch o nelle versioni del service pack di Dell EMC SourceOne Email Management a partire da 7.2.SP10 HF3 (7.2.10.0076). I kit di patch e service pack di Dell EMC SourceOne sono disponibili per il download all'indirizzo https://support.dell.com.
È disponibile un hotfix per i clienti che eseguono EMC SourceOne Email Management 7.2.SP9 e 7.2.SP10. Contattare il supporto tecnico EMC, condividere l'articolo della nota di supporto e il numero SDR (63291) con il responsabile del supporto.
Ogni sito può avere motivi diversi per cui le chiamate a livello di codice impiegano più tempo del previsto. È possibile seguire la procedura riportata di seguito per aumentare il timeout, consentendo di visualizzare l'elenco delle cartelle per la selezione nel caso in cui non sia possibile identificare la root cause del ritardo:
Dopo aver apportato la modifica, salvare e chiudere il file web.config.
Nota: Il valore è specificato in millisecondi. Un valore impostato su 180.000 consente un timeout di 180 secondi. Può essere modificato in base agli ambienti dei clienti, ad esempio, per l'impostazione di 2 minuti, il valore di timeout è 120.000.
È disponibile un hotfix per i clienti che eseguono EMC SourceOne Email Management 7.2.SP9 e 7.2.SP10. Contattare il supporto tecnico EMC, condividere l'articolo della nota di supporto e il numero SDR (63291) con il responsabile del supporto.
Ogni sito può avere motivi diversi per cui le chiamate a livello di codice impiegano più tempo del previsto. È possibile seguire la procedura riportata di seguito per aumentare il timeout, consentendo di visualizzare l'elenco delle cartelle per la selezione nel caso in cui non sia possibile identificare la root cause del ritardo:
- Ottenere il file della libreria dal team di supporto Dell EMC o assicurarsi di utilizzare la versione di SourceOne Email Management contenente l'hotfix. Se si è ottenuto il file della libreria dal team di supporto Dell EMC, eseguire il backup del binario esistente e installare il nuovo binario fornito nella cartella di installazione di SourceOne Web Search contenente il file della libreria, ad esempio "E:\Program Files (x86)\EMC SourceOne\Search\WebApp\bin".
- Passare alla directory di installazione di SourceOne Web Search contenente il file web.config, ad esempio "E:\Program Files (x86)\EMC SourceOne\Search\WebApp".
- Creare una copia del file web.config e salvarlo in un'altra posizione come backup del file di configurazione originale.
- Modificare il file web.config e all'interno della <sezione appSettings></appSettings> aggiungere la riga seguente:
<add key="SearchWebServiceTimeoutSeconds" value="180000" />
Dopo aver apportato la modifica, salvare e chiudere il file web.config.
Nota: Il valore è specificato in millisecondi. Un valore impostato su 180.000 consente un timeout di 180 secondi. Può essere modificato in base agli ambienti dei clienti, ad esempio, per l'impostazione di 2 minuti, il valore di timeout è 120.000.
- Accedere a SourceOne Web Search e testare l'operazione Restore.
Additional Information
Il problema viene riscontrato sui server SourceOne Web Search in cui è installato Microsoft Outlook 2013, 2016 o 2019. Nei server SourceOne Web Search, se è installato Outlook 2010 SP2, il problema è stato risolto. Gli aggiornamenti più recenti per Microsoft Outlook versione 2013, 2016 o 2019, al momento della redazione di questo articolo della Knowledge Base (3 maggio 2021), non risolvono il problema.
Affected Products
SourceOne, SourceOne, SourceOne Archiving, SourceOne Email ManagementArticle Properties
Article Number: 000186076
Article Type: Solution
Last Modified: 02 Sept 2025
Version: 9
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