NVP vProxy:Linux仮想マシンにFLRエージェントをインストールできない。
Summary: NetWorker VMware Protection (NVP) vProxyアプライアンスで保護されているLinux仮想マシン(VM)のファイル レベル リカバリー(FLR)中に、以下のことが発生しました。FLRマウントが失敗し、FLRエージェントがインストールされておらず、仮想マシンでインストールが許可されていないと表示されます。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
問題で生じた現象を簡単に説明してください。
- FLR中にroot以外のアカウントが指定されました。
- FLRは、NetWorker Management Console (NMC)またはDell EMC Data Protection Restore Clientから開始されました。
- リカバリー ウィザードのマウント出力で、以下のエラーが確認されました。
159373:nsrvproxy_flr: vProxy Log: 2022-02-08T11:49:06Z ERROR: [@(#) Build number: 153] Cannot connect to vProxy Agent: Unable to connect to ':9613': dial tcp :9613: connect: connection refused 159373:nsrvproxy_flr: vProxy Log: 2022-02-08T11:49:06Z INFO: [@(#) Build number: 153] FLR Agent is not installed on VM 159373:nsrvproxy_flr: vProxy Log: 2022-02-08T11:49:06Z INFO: [@(#) Build number: 153] Set custom attribute 'Dell EMC vProxy FLR Session' value for object vm-XX to ''. 159373:nsrvproxy_flr: vProxy Log: 2022-02-08T11:49:06Z INFO: [@(#) Build number: 153] Unlocked virtual machine. 159373:nsrvproxy_flr: vProxy Log: 2022-02-08T11:49:06Z INFO: [@(#) Build number: 153] Disconnected from session on vCenter 'XXXXX'. 159373:nsrvproxy_flr: vProxy Log: 2022-02-08T11:49:06Z ERROR: [@(#) Build number: 153] FLR Agent is not installed on the virtual machine and the request does not allow installation. 152793:nsrvproxy_flr: vProxy Log EndsvProxyのログの場所をマウントします。
- /opt/emc/vproxy/runtime/logs/vflrd/
- /opt/emc/vproxy/runtime/logs/recycle/vflrd/
NetWorkerサーバーのログの場所をマウントします。
- /nsr/logs/adhoc/nsrvproxy_flr
- /nsr/logs/recover/recover_name(NMCから実行され、リカバリー セッションが保存された場合)。
ターゲットVM上のFLRエージェントの場所は次のとおりです。
- /opt/emc/vproxyra/
Cause
この問題の原因としては、以下のようないくつかの可能性が考えられます。
- FLRエージェントがインストールされていない。これは、FLRエージェントをインストールするために必要な権限(または強化されたセキュリティ環境)をユーザーが持っていない場合に発生する可能性があります。
- エージェントはインストールされている可能性がありますが、FLRマウント ユーザーは、FLRエージェントのインストールを確認するために使用される自動スクリプトを実行できない可能性があります。
- ターゲットVMにインストールされているウイルス対策ソフトウェアが、FLRエージェントのインストールをブロックしている。
Resolution
FLRエージェントがインストールされていることを確認します。FLRマウント プロセスのユーザーが、エージェントのインストールを確認するスクリプトを実行できることを確認します。
1.FLRマウント中に使用した認証情報を使用してLinux VMにログインし、シェル コンソールを開きます。
2.次のコマンドを実行して、エージェントがインストールされているか、およびユーザーにエージェントを使用する権限があるかどうかを確認します。 /opt/emc/vproxyra/bin/vflragentc
vflragetc
[admin@rhel-client01 ~]$ /opt/emc/vproxyra/bin/vflragentc
vflragentc program started
AgentResponse:{"Protocol":1,"AgentVersion":{"Release":"4.4.0-14_1","BuildNumber":"1","BuildStamp":"2025-08-22T06:06:47Z"},"Mountpoint":"","OutputFile":"","IncomingDir":"","UpgradeFile":"","Filename":"","ErrorMessage":"An agent command must be specified.","ActivityLog":"","AppAgentData":{"Protocol":0,"Agent":"","Version":{"Complete":"","Numbers":null,"Build":"","Comment":""},"MetadataValues":null,"MetadataFiles":null,"DownloadFiles":null,"FilesList":null,"WorkDir":"","Operation":0,"MonitorData":null,"AppData":"","BrowseResults":null,"Utilization":null}}
メモ: このコマンドでエラーが返された場合は、root以外のユーザー アカウントに、『NetWorker VMware統合ガイド』に記載されている必要なOS権限があることを確認します。
3.エージェントがインストールされている場合は、起動されているかどうかを確認します。 /opt/emc/vproxyra/bin/vflragent status
4.エージェントが起動していない場合は、次の手順で起動を試みます。 /opt/emc/vproxyra/bin/vflragent start
エージェントが以前にこの VM にインストールされていない場合。rootアカウントは、FLRリカバリー プロセス中にFLRエージェントをインストールするために使用できます。エージェントがインストールされると、それ以降のFLRはroot以外のアカウントを使用して実行できます。root以外のユーザーは、次のリンクから入手できる『NetWorker VMware統合ガイド』に記載されている適切なオペレーティング システム権限を持っている必要があります。NetWorkerのサポート |マニュアルおよび文書
NetWorker Webユーザー インターフェイス(NWUI)方式:
NWUIサーバーがNetWorker環境にインストールされている場合は、FLR中に[Run with elevated privileges]を指定できます。このオプションは、NMCまたはData Protection Restore Clientでは使用できません。
https://NetWorker_Server:9090/nwui
NWUIがNetWorkerサーバーにインストールされているかどうかを確認します(NetWorker Virtual Editionではデフォルトで含まれています)。
Linuxの場合
rpm -qa | grep lgtonwui
Windowsの場合:
wmic product get name, version, vendor | find "Web UI Server"
手動インストール方式
FLRプロセスでエージェントをインストールできない場合は、vProxyアプライアンスからターゲットVMにエージェントをコピーし、OSコマンドを使用してローカルにインストールします。
1.FLRエージェントをインストールするVMへのSSHセッションを開きます。
2.セキュア コピー プロトコル(
scp)コマンドを使用して、FLRエージェントをvProxyからVMにコピーします。
scp admin@vPROXY_ADDRESS:/opt/emc/sw-repo/vflragent/linux/emc*.rpm TARGET-DOWNLOAD-DIRECTORY
Example:
[admin@rhel-client01 ~]$ scp admin@nsr-vproxy01:/opt/emc/sw-repo/vflragent/linux/emc*.rpm .
The authenticity of host 'nsr-vproxy01 (192.168.9.151)' can't be established.
ED25519 key fingerprint is SHA256:ZsV1JnrdzQ2DdcY1gH9bOrCFnEgBsABruninvAGaPEg.
This key is not known by any other names
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added 'nsr-vproxy01' (ED25519) to the list of known hosts.
admin@nsr-vproxy01's password:
emc-vProxy-FLRAgent-4.4.0-14_1.x86_64.rpm 100% 19MB 153.7MB/s 00:00
[admin@rhel-client01 ~]$
メモ: このコマンドは、FLRエージェントをターゲットLinux VM上のFLRユーザーのホーム ディレクトリーにコピーするものです。または、vProxyアプライアンスへのSSHセッションを開き、FLRエージェントをLinux VMにscpすることもできます。コマンドの例:
scp /opt/emc/sw-repo/vflragent/linux/emc*.rpm VM_USERNAME@VM_ADDRESS:~
3.エージェントがコピーされたLinux仮想マシンに、FLRユーザーの認証情報を使用してログインします。
4.次のコマンドを実行して、FLRエージェントをインストールします。
sudo rpm -ivh emc*.rpm
[admin@rhel-client01 ~]$ sudo rpm -ivh emc*.rpm [sudo] password for admin: warning: emc-vProxy-FLRAgent-4.4.0-14_1.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID ff48d101: NOKEY Verifying... ################################# [100%] Preparing... ################################# [100%] Updating / installing... 1:emc-vProxy-FLRAgent-4.4.0-14_1 ################################# [100%]
5.エージェントがインストールされていることを確認します。
6.インストール後のスクリプトを実行します。
7.FLRユーザーがエージェント検証コマンドを実行できることを確認します。
rpm -qa | grep -i flragent
6.インストール後のスクリプトを実行します。
sudo /opt/emc/vproxyra/bin/postinstall.sh
7.FLRユーザーがエージェント検証コマンドを実行できることを確認します。
/opt/emc/vproxyra/bin/vflragentc
[admin@rhel-client01 ~]$ /opt/emc/vproxyra/bin/vflragentc
vflragentc program started
AgentResponse:{"Protocol":1,"AgentVersion":{"Release":"4.4.0-14_1","BuildNumber":"1","BuildStamp":"2025-08-22T06:06:47Z"},"Mountpoint":"","OutputFile":"","IncomingDir":"","UpgradeFile":"","Filename":"","ErrorMessage":"An agent command must be specified.","ActivityLog":"","AppAgentData":{"Protocol":0,"Agent":"","Version":{"Complete":"","Numbers":null,"Build":"","Comment":""},"MetadataValues":null,"MetadataFiles":null,"DownloadFiles":null,"FilesList":null,"WorkDir":"","Operation":0,"MonitorData":null,"AppData":"","BrowseResults":null,"Utilization":null}}
Additional Information
Affected Products
NetWorkerArticle Properties
Article Number: 000198224
Article Type: Solution
Last Modified: 17 Nov 2025
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.