PowerEdge: Remote Desktop License popup warning sessions are disconnected
Summary: When users connect to a Remote Desktop session host, they receive a popup indicating that their session will be disconnected in 60 minutes.
Symptoms
The following popup appears shortly after a user establishes a connection to a Remote Desktop session host:
Figure 1: A popup window indicating that a Remote Desktop session will be disconnected in 60 minutes.
Users' Remote Desktop sessions are indeed disconnected after 60 minutes.
Cause
- The Remote Desktop Session Host server uses Per User licensing and is in a workgroup.
- The Remote Desktop Session Host server uses Per User licensing and is in a domain, but affected users are logging into local accounts on the server rather than domain accounts.
Resolution
Cause 1: The Remote Desktop Session Host server uses. Per User licensing, and is in a workgroup.
As stated by Microsoft here and in other locations, Per User licensing does not function properly in a workgroup. In order to use Per User licensing, an Active Directory (AD) domain is required. If a domain is already present in the environment, the session host should be made a domain member, after which Per User licensing functions properly.
If there is no AD domain present in the environment, there are two options for resolving the issue:
-
This is the simplest option by far. Convert the installed Per User client access licenses (CALs) to Per Device CALs by following the steps in How to Convert Windows Remote Desktop CALs from Per User to Per Device or Vice Versa. As stated in that article, it is also necessary to change the licensing mode of the deployment from Per User to Per Device.
-
Create an AD domain by promoting a server in the environment (preferably not the session host) to a domain controller, then join the session host to the domain. This is not a trivial process, and the domain requires ongoing administration.
Cause 2: The session host server uses. Per User licensing, and is in a domain, but affected users log in to local server accounts rather than domain accounts.
whoami command from a command prompt within a user's Remote Desktop session. The output is in domain\username format. If the domain portion of the output is equal to the name of the session host server, the user is logged into a local account.
Resolving Cause 2 is simple: Ensure that users have accounts in the AD domain and log in to those accounts when connecting to the Remote Desktop session host. When prompted for credentials, specifying the username in
domain\user format accomplishes this.