PowerEdge: Error "Falló la relación de confianza entre la estación de trabajo y el dominio principal" en el servidor Windows o en el equipo cliente
Summary: Una máquina con Windows unida a un dominio de Active Directory (AD) muestra el error "Se produjo un error en la relación de confianza entre esta estación de trabajo y el dominio principal". Esto sucede cuando un usuario intenta iniciar sesión en el dominio. A menudo, este problema se puede resolver si se elimina el equipo del dominio y se vuelve a agregar. ...
Symptoms
The trust relationship between this workstation and the primary domain failed.
Cause
Este error se produce cuando se rompe el canal seguro entre la máquina afectada y AD. El canal seguro es el mecanismo por el cual las máquinas unidas a un dominio se comunican de forma segura con las controladoras de dominio y depende de la contraseña asociada a una cuenta de equipo.
Cada computadora unida a un dominio tiene una cuenta en AD y cada cuenta de computadora tiene una contraseña asociada. Estas contraseñas de cuenta de computadora son independientes de las contraseñas de cuenta de usuario y se administran, sincronizan y actualizan automáticamente sin necesidad de interacción del usuario. Sin embargo, en algunas situaciones, la propia copia de la contraseña de la computadora deja de estar sincronizada con la copia almacenada en AD. Cuando esto sucede, no se puede establecer el canal seguro y se muestra el error anterior cuando un usuario intenta iniciar sesión en el dominio.
Resolution
Este problema se suele resolver mediante la eliminación del equipo afectado del dominio; para ello, se debe agregar a un grupo de trabajo y, a continuación, volver a agregarlo al dominio. Esto se puede lograr mediante los siguientes pasos:
- Inicie sesión en una cuenta administrativa local en el equipo afectado.
- Inicie la ventana Propiedades del sistema. Según la versión de Windows que se ejecuta en el equipo, existen varias maneras de lograr esto.
- En Windows Server, inicie el Administrador del servidor, haga clic en Servidor local en el panel izquierdo y haga clic en el nombre del dominio en el panel principal.
- En un cliente de Windows, haga clic en el icono Inicio y comience a escribir configuración avanzada del sistema. Seleccione Ver la configuración avanzada del sistema cuando aparezca la opción.
- En la pestaña Nombre del equipo, haga clic en el botón Cambiar.
- Seleccione Grupo de trabajo y escriba el nombre de un grupo de trabajo. El nombre específico no importa, ya que se trata de un grupo de trabajo temporal. Haga clic en Aceptar.
- Haga clic en Aceptar para confirmar los cuadros de diálogo que se muestran.
- Haga clic en Cerrar para cerrar la ventana Propiedades del sistema. Reinicie la computadora cuando pueda hacerlo.
- Cuando se le solicite iniciar sesión, inicie sesión en la misma cuenta administrativa local que antes.
- Inicie la ventana Propiedades del sistema.
- En la pestaña Nombre del equipo, haga clic en el botón Cambiar.
- Seleccione Dominio y escriba el nombre del dominio de AD. Haga clic en Aceptar.
- Proporcione las credenciales de una cuenta de usuario de dominio que tenga permiso para agregar la computadora al dominio. Haga clic en Aceptar.
- Haga clic en Aceptar para confirmar los cuadros de diálogo que se muestran.
- Haga clic en Cerrar para cerrar la ventana Propiedades del sistema. Reinicie la computadora cuando pueda hacerlo.
- En el mensaje de inicio de sesión, confirme que ahora puede iniciar sesión en una cuenta de dominio sin recibir un error.