Dell Unity: Replication Bandwidth schedules are not working as expected (User Correctable)

Summary: This article explains why bandwidth schedules do not synchronize at the expected time when the time zone is set to any time zone other than UTC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Synchronization does not start at the expected time the bandwidth is scheduled when the time zone is set to any time zone other than UTC. This behavior is reported in Dell Unity OE 5.2.

Cause

When Replication is paused on a schedule, the session goes into the suspend pool. This is caused by an issue in the code where the scheduler uses UTC time ignoring the current time zone.

Example:
The bandwidth is synchronized between 09:00 Saturday and 07:00 Monday, Japan time (JST).
-------------------------------------------------
[Bandwidth Schedule]
Schedule time zone: UTC+9:00 (Tokyo)
-------------------------------------------------
Monday - Friday
 00:00 - 07:00 Maximum Bandwidth is 40,960 KBs.
 07:00 - 24:00 Maximum Bandwidth is 0 KBs.
Sat - Sun
 24:00 - 24:00 Maximum Bandwidth is 40,960 KBs.
-------------------------------------------------
The mechanism is as follows:
The session is suspended because the bandwidth is set at 0 KBs at 07:00 JST Japan time on Monday.

The suspended session is placed in the suspend pool.

The scheduler checks the suspend pool every hour to see if the session can be transferred.

In the case of this schedule, the session is set to be available for transfer from Tuesday 00:00 JST, but when checking the suspend pool, the scheduler tries to start transfer at Tuesday 00:00 UTC (09:00 AM JST) because it does not take the time zone into account.

However, since UTC 00:00-07:00 is JST 09:00-16:00 and the bandwidth from 09:00-16:00 JST is set at 0 KB, the transfer will not start.

The operation is then repeated, and at 00:00 UTC (09:00 JST) on Saturday, synchronization begins because the bandwidth is set at 40,960 KB.

In this example, the issue occurred in JST. However, the issue may occur in other time zones except UTC.

Resolution

Resolution:
This issue is scheduled to be addressed in the next Unity OE release.

Workaround:
Choose either of the two workaround options:

  • Option1 if you must have 0 KB of bandwidth.
  • Option2 if you do not want to change the time zone.

Option1:
If you want to use 0 KB, change the time zone to UTC and set the schedule.
 

WARNING: Do not use Option1 0 KB if using User Snap Replication.
A panic reboot of the SP may occur. To be fixed in OE 5.3.


Option2:
If the time zone cannot be changed, instead of using a zero value for the bandwidth schedule, use a small value (for example, 10 KB, and so forth) so that the session is not placed in the suspend pool, thus avoiding the issue.

Affected Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition ...

Products

Dell Unity Operating Environment (OE)
Article Properties
Article Number: 000204177
Article Type: Solution
Last Modified: 22 May 2023
Version:  6
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