PowerStore: Cloning a NAS Server may fail if there are a large number of file systems being cloned simultaneously.

Summary: When cloning an existing NAS Server (and its file systems), the cloning operation may fail to clone all the file systems if there are more than 100 file systems.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A user can clone a NAS Server using PowerStore Manager > Storage > NAS Servers > REPURPOSE > Clone NAS Server, but cloning job fails with the error message: The connection to the PowerStore was lost during the request. It is recommended to verify the operation has completed, or try again.
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Cause

When there are a large number of objects involved in the NAS Server cloning operation, the Control Path request to SDNAS may timeout, resulting in some of the file systems not being cloned. Specifically, the clone job works asynchronously, and if not completed within 10 minutes times out.

Resolution

Clone the NAS Server with fewer file systems, for example, clone of less than 100 file systems should not be affected by the timeout.
Or, clone the NAS Server without any file systems specified.

Affected Products

PowerStore
Article Properties
Article Number: 000213912
Article Type: Solution
Last Modified: 05 Sept 2025
Version:  3
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