PowerProtect: Oracle agent is creating many oracle audit log files.

Summary: Large number of Oracle audit files get generated during PPDM Oracle agent operations.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

During regular PPDM Oracle operations, Oracle audit log files would be generated during various asset discovery operations. In addition, depending on the Oracle audit trail settings, errors similar to ORA-09925 error, or the disk full issue on the partition where the Oracle audit_file_dest directory located can be encountered.

Cause

During regular PPDM Oracle discovery operations, a number of connections to the Oracle database are being performed.  This results in an Oracle audit trail log to be generated.

Resolution

To reduce the frequency of the number of logs being generated, the user can change the value of the Agent Service configuration parameter adhocDiscoveryStatusChecktimeout from 600 to a larger number such as 1200 (measured in seconds) The Agent Service configuration file config.yml is located in /opt/dpsapps/agentsvc directory on Linux and AIX. After modifying the config.yml file, it is necessary to restart the powerprotect-agentsvc on the Oracle client. This will increase the amount of time between discoveries on the Oracle host, which would then create less audit trail files. 

The user can also reference the Oracle Corp. audit trail user documentation to clean the audit trail files or the audit trail table space. The Oracle audit trails provide the ability to automatically clean the audit trail files. For more details please check the Oracle Corp. Oracle audit trails online document.

Article Properties
Article Number: 000213920
Article Type: Solution
Last Modified: 14 May 2025
Version:  1
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