Der Fehler 404 vom PowerFlex Gateway
Summary: Während eines RCM-Upgrades wird bei der Anmeldung bei der PowerFlex Gateway -Benutzeroberfläche ein 404-Fehler angezeigt.
Symptoms
- Das Gateway wurde mithilfe von RCM 3.6.5 aktualisiert.
- Beim Anmelden bei der PowerFlex Gateway -UI wird Folgendes angezeigt:

- Die Gateway-scaleio.log zeigt diese Ausgabe an:
2024-02-08 09:13:09,094 [localhost-startStop-1] ERROR c.e.s.s.services.RequestMapUtils - vasa.provider.monitor.interval.seconds (60,60) must be a number between -2147 483648, 2147483647.
Auswirkungen
Das Upgrade kann erst fortgesetzt werden, wenn das Gateway verfügbar ist.
Cause
Ursache
An die Datei "/opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties" wurden viele Parameter fälschlicherweise mit einem Komma und dem bereits in der Zeile angegebenen Wert angehängt.
Beispiel:
vasa.provider.ips=, vasa.provider.monitor.port=, vasa.provider.monitor.interval.seconds=60,60 #vasa.provider.replica.set.name=vasa-rs .. lia.ldap.commands.batch.size=256,256 upload.commands.batch.size=16,16 lia.upload.commands.batch.size=256,256 validate.node.commands.batch.size=256,256 cloudiq.enabled=true,true
Resolution
Auflösung
Das Problem kann behoben werden, indem die Parameter "/opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties" auf die Werte festgelegt werden. Wenn Sie sich nicht sicher sind, verwenden Sie ein anderes Gateway zum Vergleich. Das Beispiel erhebt keinen Anspruch auf Vollständigkeit. Mehr Zeilen, die mit den falschen Parametern angehängt wurden.
Im obigen Beispiel sollten die Zeilen wie folgt aussehen:
vasa.provider.ips= vasa.provider.monitor.port= vasa.provider.monitor.interval.seconds=60 #vasa.provider.replica.set.name=vasa-rs .. lia.ldap.commands.batch.size=256 upload.commands.batch.size=16 lia.upload.commands.batch.size=256 validate.node.commands.batch.size=256 cloudiq.enabled=true
In den Leerzeilen wurden die Kommas entfernt, und in den Zeilen mit tatsächlichen Werten wurden das Komma und der zusätzliche Wert entfernt.
Starten Sie anschließend den Gateway-Service neu:
# systemctl restart scaleio-gateway
Betroffene Version
PowerFlex RCM 3.6.5
Behoben in Version
PowerFlex RCM 3.8.8