Errore 404 visualizzato dal gateway PowerFlex
Summary: Durante un upgrade RCM, l'accesso all'interfaccia utente del gateway PowerFlex mostra un errore 404.
Symptoms
- Il gateway è stato aggiornato utilizzando RCM 3.6.5
- Accedendo all'interfaccia utente del gateway PowerFlex, viene visualizzato quanto segue:

- Il gateway scaleio.log mostra questo output:
2024-02-08 09:13:09,094 [localhost-startStop-1] ERROR c.e.s.s.services.RequestMapUtils - vasa.provider.monitor.interval.seconds (60,60) must be a number between -2147 483648, 2147483647.
Impatto
L'aggiornamento non può continuare fino a quando il gateway non è disponibile.
Cause
Causa
Nel file "/opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties" molti parametri sono stati aggiunti in modo errato con una virgola e il valore già presente nella riga.
Esempio:
vasa.provider.ips=, vasa.provider.monitor.port=, vasa.provider.monitor.interval.seconds=60,60 #vasa.provider.replica.set.name=vasa-rs .. lia.ldap.commands.batch.size=256,256 upload.commands.batch.size=16,16 lia.upload.commands.batch.size=256,256 validate.node.commands.batch.size=256,256 cloudiq.enabled=true,true
Resolution
Risoluzione
Il problema può essere risolto impostando i parametri "/opt/emc/scaleio/gateway/webapps/ROOT/WEB-INF/classes/gatewayUser.properties" su quelli che dovrebbero essere. In caso di dubbi, utilizzare un altro gateway per effettuare il confronto. L'esempio non è esaustivo. Più righe a cui sono stati aggiunti i parametri errati.
Nell'esempio precedente, le righe dovrebbero essere simili a queste:
vasa.provider.ips= vasa.provider.monitor.port= vasa.provider.monitor.interval.seconds=60 #vasa.provider.replica.set.name=vasa-rs .. lia.ldap.commands.batch.size=256 upload.commands.batch.size=16 lia.upload.commands.batch.size=256 validate.node.commands.batch.size=256 cloudiq.enabled=true
Le righe vuote sono state rimosse le virgole e le righe con valori effettivi sono state rimosse la virgola e il valore aggiuntivo.
Al termine dell'operazione, riavviare il servizio gateway:
# systemctl restart scaleio-gateway
Versione interessata
PowerFlex RCM 3.6.5
Risolto nella versione
PowerFlex RCM 3.8.8