Log Retrieval Fails in DDEBA 19.13 DB2 v10.5 RHEL6

Summary: DB2 Log Retrieval fails Causing both Backup and Restore failures

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

DB2 Log Retrieval fails Causing both Backup and Restore failures.

DB2DIAG logs Error
MESSAGE : ADM8010E  Backup was unable to copy requested log file "S000xxxxx.LOG"  for inclusion in the backup image. The backup has been aborted.
ddboost_db2.messages.10002.raw Error
Fail to construct sub-spacename, either instance or database or node name is missing

 "libddboostdb2_std_*" debug log Messages, the db2instance="*" instead of the actual instance name.

{
   DB2_session ={
      DB2_id ="SQL1005B",
      "version =""10",
      "release =""05",
      "level =""B",
      "action =""L",
      "filename =""C???????_S00000XX.LOG",
      server_id = 0x0,
      db2instance ="*", ---------------------------------------------> Wild Card here is not correct!!
      "type =""0",
      "dbname =""INSTNAME",
      "alias =""INSTNAME",
      "timestamp =""",
      "sequence =""0",
      obj_list = 0x0,
      max_bytes_per_txn = 32768 image_filename = 0x0,
      "reserve = (nil)",
      "nodename =""",
      password = 0x7f8c3be0810e,
      "owner =""",
      "mcNameP =""*",
      dbPartition = 0
   }size_options = 27,
   size_HI_order = 0,
   size_LOW_order = 4202496,
   "options =""@/opt/dpsapps/db2_ddbda.cfg",
   "reserve =(nil)",
   prompt_lvl = 0x0,
   num_sessions = 1
}

Cause

Problem with DDBEA/App agent 19.13 code

Resolution

Downgrade DDEBA to 19.8.

Affected Products

Data Protection Suite
Article Properties
Article Number: 000223550
Article Type: Solution
Last Modified: 23 Oct 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.