IDPA: Błąd ignorowany jest przy użyciu dodatkowych znaków w wierszu konfiguracji: podczas konfiguracji zdalnego rejestrowania (przekazywanie syslogu) w ACM
Summary: Błąd "zignorowano dodatkowe znaki w wierszu konfiguracji: '*' [v8.2106.0] " podczas konfiguracji zdalnego rejestrowania (przekazywanie syslogu) w ACM. Problem dotyczy konfiguracji zdalnego rejestrowania (przekazywania syslogu) w ACM. Komunikat o błędzie "Zignorowano dodatkowe znaki w wierszu konfiguracji: Podczas próby ponownego uruchomienia usługi rsyslog występuje błąd "*" [v8.2106.0], który uniemożliwia przekazywanie dzienników do serwera zdalnego. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Podczas próby ponownego uruchomienia usługi rsyslog przy użyciu poniższego polecenia operacja kończy się niepowodzeniem.
Po sprawdzeniu stanu rsyslog za pomocą poniższego polecenia zostanie wyświetlony komunikat o błędzie:
Ten błąd uniemożliwia przekazywanie dzienników do serwera zdalnego. Problem jest związany z obcym znakiem "*" w pliku /etc/rsyslog.conf, który należy usunąć.
systemctl restart
Po sprawdzeniu stanu rsyslog za pomocą poniższego polecenia zostanie wyświetlony komunikat o błędzie:
systemctl status rsyslog
error: extra characters in config line ignored: ‘’ [v8.2106.0]"
Ten błąd uniemożliwia przekazywanie dzienników do serwera zdalnego. Problem jest związany z obcym znakiem "*" w pliku /etc/rsyslog.conf, który należy usunąć.
# systemctl status rsyslog ● rsyslog.service - System Logging Service Loaded: loaded (/usr/lib/systemd/system/rsyslog.service; enabled; vendor preset: disabled) Active: active (running) since Tue 2024-04-02 14:32:04 UTC; 6s ago Docs: man:rsyslogd(8) http://www.rsyslog.com/doc/ Process: 27195 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCESS) Process: 40849 ExecStartPre=/usr/sbin/rsyslog-service-prepare (code=exited, status=0/SUCCESS) Main PID: 40853 (rsyslogd) Tasks: 10 (limit: 512) CGroup: /system.slice/rsyslog.service └─40853 /usr/sbin/rsyslogd -n -iNONE Apr 02 14:32:04 acm-8300-crk systemd[1]: Starting System Logging Service... Apr 02 14:32:04 acm-8300-crk systemd[1]: Started System Logging Service. Apr 02 14:32:04 acm-8300-crk rsyslogd[40853]: error: extra characters in config line ignored: '*' [v8.2106.0] Apr 02 14:32:04 acm-8300-crk rsyslogd[40853]: warning: ~ action is deprecated, consider using the 'stop' statement instead [v8.2106.0 try https://www.rsyslog.com/e/2307 ] Apr 02 14:32:04 acm-8300-crk rsyslogd[40853]: imuxsock: Acquired UNIX socket '/run/systemd/journal/syslog' (fd 3) from systemd. [v8.2106.0] Apr 02 14:32:04 acm-8300-crk rsyslogd[40853]: origin software="rsyslogd" swVersion="8.2106.0" x-pid="40853" x-info="[https://www.rsyslog.com start
Cause
Błąd jest spowodowany dodatkową gwiazdką ('*') obecną w pliku /etc/rsyslog.conf. Należy usunąć ten element w celu zapewnienia prawidłowej konfiguracji i działania przekazywania syslogu.
Resolution
1. Sprawdź, czy pakiet rsyslog jest zainstalowany:
acm:~ # rpm -qa |grep rsyslog rsyslog-8.24.0-3.39.1.x86_64
2. Sprawdź, czy usługa rsyslog jest włączona:
acm:~ # systemctl is-enabled rsyslog enabled
3.Otwórz plik /etc/rsyslog.conf w edytorze tekstu.
Usuń znak "*" z poniższego wiersza i dodaj wpis Syslog.
Usuń znak "*" z poniższego wiersza i dodaj wpis Syslog.
$template RemoteLogs,"/data01/logs/ESX/%HOSTNAME%/%PROGRAMNAME%.log"* =>Extra
$template RemoteLogs,"/data01/logs/ESX/%HOSTNAME%/%PROGRAMNAME%.log"
*.* ?RemoteLogs
&~
Po zmianach
$template RemoteLogs,"/data01/logs/ESX/%HOSTNAME%/%PROGRAMNAME%.log" $template RemoteLogs,"/data01/logs/ESX/%HOSTNAME%/%PROGRAMNAME%.log" *.* @xxx.xxx.xxx.xxx:514 &~gdzie xxx.xxx.xxx.xxx jest adresem IP zdalnego hosta rejestrowania.
4. Zapisz i zamknij plik.
:wq!5. Uruchom ponownie proces rsyslog, wpisując następujące polecenie:
# systemctl restart rsyslog
Affected Products
Integrated Data Protection Appliance FamilyProducts
Integrated Data Protection Appliance SoftwareArticle Properties
Article Number: 000225742
Article Type: Solution
Last Modified: 20 June 2024
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.