PowerFlex: Avvisi di annullamento del percorso di rete
Summary: PowerFlex versione 3.6 e successive rileva quando una porta o un socket si disconnette frequentemente (intermittenza) e disabilita in modo proattivo il percorso, impedendo interruzioni generali nel sistema. I clienti devono indagare sull'origine delle interruzioni con il proprio team interno. ...
Symptoms
Gli utenti possono visualizzare uno o più avvisi, come quelli riportati di seguito:
- Un percorso è squalificato: "the path between x.x.x.x and x.x.x.x" (il livello di gravità di questo avviso è "Minor")
- Oppure diversi percorsi sono squalificati: "i percorsi tra x.x.x.x, e x.x.x.x, x.x.x.x e x.x.x.x sono squalificati" (il livello di gravità di questo avviso è "Importante")
PowerFlex 3.6: Avvisi nel server di presentazione
PowerFlex 4.x: Avvisi in PowerFlex Manager
Cause
Gli avvisi di annullamento dell'idoneità del percorso di rete si verificano quando una porta o un socket subisce frequenti disconnessioni (flapping), che possono causare problemi di prestazioni del sistema nell'architettura completamente distribuita di PowerFlex. PowerFlex lo rileva e disabilita in modo proattivo il percorso, evitando interruzioni generali in tutto il sistema. Tra le cause più comuni di instabilità delle porte vi sono: Scheda di rete difettosa, problemi con i cavi o interruzione di rete
Resolution
Per isolare l'origine del problema, attenersi alla seguente procedura:
- Eseguire il ping dell'indirizzo IP del componente o dei componenti elencati nell'avviso. Se il ping ha esito positivo, non è necessario eseguire ulteriori procedure di risoluzione dei problemi.
- Aprire una sessione SSH sull MDM primario e inserire il seguente comando:
scli --query_port_flapping_status --all
In genere, la porta si attiva automaticamente quando l'origine del problema viene risolta. L'utente non deve attivare manualmente una porta, a meno che la porta non vada in modalità err-disabled sullo switch. In tal caso, l'esecuzione di un arresto e nessun arresto sulla porta dello switch dovrebbe risolvere il problema.
Una volta che la porta è di nuovo online, l'avviso dovrebbe cancellarsi da solo nel tempo; Tuttavia, se l'utente deve cancellare l'avviso, la seguente procedura contribuirà a raggiungere questo obiettivo:
-
Per cancellare gli avvisi nelle versioni PowerFlex versione 3.x e precedenti, attenersi alla seguente procedura:
- Reimpostazione dei passaggi dei parametri del contatore di errori oscillanti in KB PowerFlex Come reimpostare gli errori di oscillazione e PowerFlex Come risolvere i parametri del contatore di errori oscillanti SIO01.03.0000001-2
- Riavviare il server di presentazione (questa operazione non ha alcun impatto e dovrebbe richiedere solo pochi minuti): Ci sono due modi per raggiungere questo obiettivo:
- Tramite vSphere: Accedere alla macchina virtuale > del server di presentazione Riavviare la macchina virtuale
- Tramite CLI: Aprire SSH per l'IP> del server di presentazione Eseguire i comandi riportati di seguito:
# systemctl stop mgmt-server # systemctl start mgmt-server
-
Per cancellare gli avvisi in PowerFlex versione 4.0 e successive, seguire la procedura elencata in questo articolo Piattaforma di gestione PowerFlex - Come cancellare manualmente gli avvisi dall'interfaccia utente di PowerFlex Manager 4.X
Se è necessario ulteriore supporto durante l'indagine, creare un caso con il caso di supporto PowerFlex e fornire i seguenti elementi:
- Schermata dell'avviso
- Registri di Get_Info dell MDM primario (l'elenco dei passaggi per raccogliere questi registri è riportato nell'articolo della KB Come generare registri get_info
Additional Information
https://www.youtube.com/watch?v=eABbCq-a9Yc
Fare riferimento a questo video:
Esclusione proattiva della rete in Dell PowerFlex: Miglioramento delle prestazioni del sistema
Durata: 00:05:18 (hh:mm:ss)
Quando disponibile, le impostazioni della lingua dei sottotitoli possono essere scelte utilizzando l'icona CC su questo lettore video.
È anche possibile visualizzare questo video su YouTube.