PowerFlex: Alerty dyskwalifikacji ścieżki sieciowej
Summary: System PowerFlex w wersji 3.6 lub nowszej wykrywa, kiedy port lub gniazdo często się rozłącza (niestabilność) i proaktywnie dyskwalifikuje ścieżkę, zapobiegając ogólnym zakłóceniom w całym systemie. Klienci muszą zbadać źródło zakłóceń wraz z wewnętrznym zespołem. ...
Symptoms
Użytkownicy mogą zobaczyć jeden lub więcej alertów, takich jak:
- Jedna ścieżka jest zdyskwalifikowana: "ścieżka między x.x.x.x i x.x.x.x" (poziom ważności tego alertu to "Minor")
- Lub kilka ścieżek jest zdyskwalifikowanych: "ścieżki między x.x.x.x i x.x.x.x, x.x.x.x i x.x.x.x są zdyskwalifikowane" (poziom ważności tego alertu to "Główny")
PowerFlex 3.6: Alerty na serwerze prezentacji
PowerFlex 4.x: Alerty w PowerFlex Manager
Cause
Alerty dyskwalifikacji ścieżki sieciowej występują, gdy port lub gniazdo często się rozłącza (wahania), co może powodować problemy z wydajnością systemu w całkowicie rozproszonej architekturze PowerFlex. PowerFlex wykrywa to i proaktywnie dyskwalifikuje ścieżkę, zapobiegając ogólnym zakłóceniom w całym systemie. Do najczęstszych przyczyn trzepotania portów należą: Wadliwa karta sieciowa, problemy z kablami lub utrata połączenia z siecią
Resolution
Aby ustalić źródło problemu, wykonaj następujące czynności:
- Wykonaj polecenie ping na adres IP elementu lub składników wymienionych w alercie. Jeśli polecenie ping zakończy się powodzeniem, nie trzeba wykonywać żadnych dodatkowych czynności rozwiązywania problemów.
- Otwórz sesję SSH do głównego MDM i wprowadź następujące polecenie:
scli --query_port_flapping_status --all
Zazwyczaj po rozwiązaniu źródła problemu port automatycznie powraca ponownie. Użytkownik nie powinien ręcznie przywoływać portu, chyba że port przejdzie w tryb Err-disabled na przełączniku. W takiej sytuacji wykonanie wyłączenia portu przełącznika bez wyłączenia powinno rozwiązać problem.
Gdy port powróci do trybu online, alert powinien z czasem zniknąć samoczynnie; Jeśli jednak użytkownik musi usunąć alert, pomogą w tym następujące kroki:
-
Aby usunąć alerty w wersjach PowerFlex 3.x i starszych, wykonaj następujące kroki:
- Resetowanie parametrów licznika awarii oscylacyjnych w bazie wiedzy PowerFlex Resetowanie błędów oscylacyjnych i PowerFlex Rozwiązywanie problemów z parametrami licznika awarii oscylacyjnych SIO01.03.0000001-2
- Uruchom ponownie serwer prezentacji (ta operacja nie ma wpływu i powinna potrwać tylko kilka minut): Można to osiągnąć na dwa sposoby:
- Za pośrednictwem vSphere: Dostęp do maszyny wirtualnej serwera prezentacji Uruchom ponownie maszynę wirtualną >
- Za pośrednictwem interfejsu wiersza poleceń: Otwieranie protokołu SSH do adresu IP> serwera prezentacji Wykonaj poniższe polecenia:
# systemctl stop mgmt-server # systemctl start mgmt-server
-
Aby usunąć alerty w PowerFlex w wersji 4.0 i nowszych, wykonaj czynności wymienione w tym artykule Platforma zarządzania PowerFlex — ręczne usuwanie alertów z interfejsu użytkownika PowerFlex Manager 4.X
Jeśli w trakcie badania potrzebna jest dodatkowa pomoc techniczna, utwórz zgłoszenie z pomocą techniczną PowerFlex i podaj następujące elementy:
- Zrzut ekranu alertu
- Główne dzienniki Get_Info MDM (lista kroków zbierania tych dzienników znajduje się w artykule bazy wiedzy Generowanie dzienników get_info
Additional Information
https://www.youtube.com/watch?v=eABbCq-a9Yc
Zapoznaj się z niniejszym filmem:
Proaktywna dyskwalifikacja sieci w systemie Dell PowerFlex: Zwiększanie wydajności systemu
Czas trwania: 00:05:18 (gg:mm:ss)
Jeśli są dostępne, ustawienia języka napisów kodowanych można wybrać za pomocą ikony CC w tym odtwarzaczu wideo.
Ten film można również obejrzeć w serwisie YouTube.