Avamar: Server 19.10+ ja avtar-asiakkaan todennusvirhe ja virhe 69

Summary: Kun Avamaria käytetään versiota 19.10 vanhemmalla asiakasversiolla, yli 20 merkkiä pitkät salasanat saattavat katketa, mikä johtaa todennusvirheisiin. Tämä ongelma koskee paikallisia käyttäjiä, eikä se koske LDAP:stä luotuja käyttäjiä. Voit ratkaista tämän ongelman varmistamalla, että asiakasversio vastaa palvelimen versiota, tai lyhentämällä salasanaa. Jos asiakasohjelman versio on vanhempi kuin 19.10.100, yli 20 merkkiä pitkät salasanat katkaistaan ja todennus epäonnistuu. Tämä rajoitus koskee kaikkia paikallisia käyttäjiä, mukaan lukien Avamar root ja MCUser. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ongelman oireet ovat seuraavat:

  • Avamar-palvelimen kirjautuminen epäonnistuu, vaikka salasana olisi oikea, mikä johtaa todennusvirheeseen (Virheellinen salasana? Käyttäjä poistettu käytöstä?) virhe.
  • Koodattu salasana ei toimi, vaikka sitä käytettäisiin selväkielisen salasanan sijasta.
  • Ongelma ilmenee, kun salasanassa on yli 20 merkkiä.
  • Ongelma ilmenee, kun Avamar-palvelimen versio on 19.10 tai uudempi ja asiakkaassa on vanhempi versio.
     
  • Näyttöön tulee seuraavat virheilmoitukset:
    • avtar Error <5126>: Login error 69: Authentication failure (Invalid password? User disabled?)
      avtar FATAL <5308>: Failed to initiate session with server
      avtar Info <6149>: Error summary: 2 errors: 5308, 5126
      avtar Info <5314>: Command failed (2 errors, exit code 10008: cannot establish connection with server (possible network or DNS failure))

Cause

Tämä avtar-todennusvirheen ongelma johtuu jommastakummasta seuraavista tilanteista:

  • Salasanan pituus: Käytetty salasana on liian pitkä ja ylittää Avamarin vanhempien versioiden 20 merkin rajan. 
  • Versiot eivät täsmää: Asiakas- ja palvelinversiot eivät täsmää, mikä on edellytys Avamar-todennukselle uuden, pidemmän merkkirajoituksen vuoksi. 

Resolution

  • Varmista, että asiakas- ja palvelinversiot vastaavat toisiaan, jotta Avamar-asiakasohjelma voidaan todentaa Avamar-palvelimen kanssa.
  • Käytä enintään 27 merkkiä pitkää salasanaa, kun Avamar-asiakasohjelma todentaa Avamar-palvelimessa, kun asiakasohjelman ja palvelimen versiot eivät täsmää.
  • Suorita avtar --backups suorittaa todennusongelmien vianmäärityksen Avamar-palvelimessa salakielisalasanan avulla.
    avtar --backups --id=exampleuser --ap=examplepassword --path=/path/to/client --server=192.168.1.1 # Replace with Avamar IP or FQDN

Jos salasanan todennuksessa ilmenee edelleen ongelmia, ota yhteys Dellin tukeen.

Affected Products

Avamar Client, Avamar Client for Linux, UNIX, MacOSX, Avamar Plug-in for IBM DB2, Avamar Plug-in for Oracle, Avamar Server
Article Properties
Article Number: 000229108
Article Type: Solution
Last Modified: 27 Sept 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.