Ошибка подключения OpenManage Enterprise CyberArk

Summary: OpenManage Enterprise не удается подключиться к центральному поставщику учетных данных (CCP) CyberArk.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

При настройке OpenManage Enterprise для использования интеграции с CyberArk тестовое подключение возвращает следующее сообщение об ошибке. Ошибка тестирования подключения

Журналы приложений показывают следующую ошибку пути сертификата: 

[WARN ] 2024-09-19 21:11:46.053 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-12] CertificateHelper - validateCertChain - Unknown revocation status 
[WARN ] 2024-09-19 21:11:46.261 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-12] CertificateHelper - validateServerAndClientEku: Client & Server authentication EKU present in leaf certificate.
[ERROR] 2024-09-19 21:13:46.232 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-8] CyberarkManagerImpl - verifyConnectionToCyberark: exception occurred while verifying the connection to cyberark. Message: I/O error on GET request for "https://pvwa.sumers.local:443/AIMWebservice/api/Accounts": PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target; nested exception is javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Cause

Эта проблема возникает из-за того, что сертификаты CA из сертификата, загруженного в OpenManage Enterprise для CyberArk, не загружаются в хранилище доверенных сертификатов при создании SSLContext для подключения HTTPS.

Resolution

Эта проблема решена в предстоящем выпуске OpenManage Enterprise 4.3.

Affected Products

Dell OpenManage Enterprise, Dell EMC OpenManage Enterprise
Article Properties
Article Number: 000231597
Article Type: Solution
Last Modified: 08 July 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.