OpenManage Enterprise CyberArk 連線錯誤
Summary: OpenManage Enterprise 無法連線至 CyberArk Central 認證提供者 (CCP)。
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Symptoms
設定 OpenManage Enterprise 以使用 CyberArk 整合時,測試連線會傳回下列錯誤訊息。
應用程式記錄顯示以下憑證路徑錯誤。
[WARN ] 2024-09-19 21:11:46.053 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-12] CertificateHelper - validateCertChain - Unknown revocation status [WARN ] 2024-09-19 21:11:46.261 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-12] CertificateHelper - validateServerAndClientEku: Client & Server authentication EKU present in leaf certificate. [ERROR] 2024-09-19 21:13:46.232 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-8] CyberarkManagerImpl - verifyConnectionToCyberark: exception occurred while verifying the connection to cyberark. Message: I/O error on GET request for "https://pvwa.sumers.local:443/AIMWebservice/api/Accounts": PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target; nested exception is javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Cause
發生此問題的原因,是在為 HTTPS 連線建立 SSLContext 時,上傳至 CyberArk OpenManage Enterprise 的憑證的 CA 憑證未載入至信任存放區。
Resolution
此問題已在即將推出的 OpenManage Enterprise 4.3 版本中解決。
Affected Products
Dell OpenManage Enterprise, Dell EMC OpenManage EnterpriseArticle Properties
Article Number: 000231597
Article Type: Solution
Last Modified: 08 July 2025
Version: 3
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