OpenManage Enterprise CyberArk 连接错误
Summary: OpenManage Enterprise 无法连接到 CyberArk Central 凭据提供程序 (CCP)。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
将 OpenManage Enterprise 配置为使用 CyberArk 集成时,测试连接返回以下错误消息。
应用程序日志显示以下证书路径错误。
[WARN ] 2024-09-19 21:11:46.053 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-12] CertificateHelper - validateCertChain - Unknown revocation status [WARN ] 2024-09-19 21:11:46.261 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-12] CertificateHelper - validateServerAndClientEku: Client & Server authentication EKU present in leaf certificate. [ERROR] 2024-09-19 21:13:46.232 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-8] CyberarkManagerImpl - verifyConnectionToCyberark: exception occurred while verifying the connection to cyberark. Message: I/O error on GET request for "https://pvwa.sumers.local:443/AIMWebservice/api/Accounts": PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target; nested exception is javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Cause
出现此问题的原因是,在为 HTTPS 连接创建 SSLContext 时,上传到 OpenManage Enterprise for CyberArk 的证书中的 CA 证书未加载到信任库中。
Resolution
此问题已在即将发布的 OpenManage Enterprise 4.3 版本中得到解决。
Affected Products
Dell OpenManage Enterprise, Dell EMC OpenManage EnterpriseArticle Properties
Article Number: 000231597
Article Type: Solution
Last Modified: 08 July 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.