Avamar:Proxy Deployment Manager - ファイルのロック エラーにより新しいプロキシを導入できない
Summary: Avamar:Proxy Deployment Manager - 「Error powering on proxy: ロックされているため、ファイルにアクセスできません」
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Symptoms
Proxy Deployment Managerを使用したVSAN環境での新しいプロキシの導入は、次の原因で失敗する可能性があります。
エラーメッセージ:「プロキシの電源投入中にエラーが発生しました: ロックされているため、ファイルにアクセスできません。」
ログの場所: このエラーは、Avamar Server上の次のログ ファイルに表示されます。
/usr/local/avamar/var/log/vcs/deploymanager.log
ログの詳細:
TRACE [Thread-39 ][ impl.ConnectionManagerService# releaseSession]: Releasing connection manager session: id=...147079090986 DEBUG [Thread-39 ][ worker.DeployWorker# run]: Powering on VM TRACE [Thread-40 ][ util.VcConnection# keepAlive]: Keep-aliving VC session TRACE [Thread-40 ][ impl.ConnectionManagerService# sendKeepAlive]: Keep-alive connection manager session: ...85fdd16e4831 WARN [Thread-39 ][ worker.DeployWorker# run]: Error powering on proxy: Unable to access file since it is locked WARN [Thread-39 ][ worker.DeployWorker# run]: Uncaught MethodFault null DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: INFO [Thread-39 ][ worker.TaskWorker# sendTaskError]: Sending fault com.vmware.vim25.LocalizedMethodFault@60a82b15 INFO [Thread-39 ][ worker.DeployWorker# run]: Deploy of proxy gnewproxyhostname.example.com (19.10.100-166) to host esxi.example.com was not successful. Cleaning up deploy artifacts... DEBUG [Thread-39 ][ worker.TaskWorker#teTaskDescription]: Updating task description: Cleaning up after error... INFO [Thread-39 ][ worker.DeployWorker# run]: keepDeployFailedProxy: false
Cause
ファイル ロックの問題の原因は次のとおりです。
- 環境要因この問題は、ほとんどの環境では発生しません。
- 電源投入試行の失敗と手動電源投入の間の遅延が不十分
- 正確な原因の特定を困難にするタイミングの問題。
Resolution
長期的な解決策
この問題に対処するホットフィックスは、AV19.9およびAV19.10SP1でリリースされる予定です。この修正は、次のAvamarメジャー リリースにも含まれます。
回避策
Dellサポートに連絡して、導入タスクと電源投入タスクの間に遅延を追加するDeployment Managerの修正バージョンをインストールしてください。
Affected Products
AvamarArticle Properties
Article Number: 000233945
Article Type: Solution
Last Modified: 29 Nov 2024
Version: 4
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