Wireless LAN Disconnects on a Dell Pro 13 Premium PA13250 or Dell Pro 14 Premium PA14250 Connected to a Dell Dock Using LAN Cable

Summary: This article provides information about why the wireless network disconnects on a Dell Pro laptop when it is connected to a Dell dock.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Wireless network may disconnect on a Dell Pro laptop. The issue occurs when the computer is connected a Dell dock using a LAN cable. However, Wireless Radio Control in the BIOS is set to off.

Affected Platforms:

  • Dell Pro 13 Premium PA13250
  • Dell Pro 14 Premium PA14250

Affected Docks:

  • Dell Dock WD19
  • Dell Thunderbolt Dock – WD22TB4

Cause

This is due to an issue in the dock firmware version 01.00.36, 01.00.20.

Resolution

Updating to Dell Dock WD19/WD22TB4 Firmware Update Utility version 01.00.44, 01.00.28 or later on the computer resolves the issue. To download and install the Firmware, reference How to Download and Install Dell Drivers.

Affected Products

Dell Pro 13 Premium PA13250, Dell Pro 14 Premium PA14250, Dell Dock WD19, Dell Thunderbolt Dock – WD22TB4
Article Properties
Article Number: 000286996
Article Type: Solution
Last Modified: 15 Apr 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.