VxRail. Клиент vSphere не отвечает после модернизации vCenter Server 8.0 Update 3b

Summary: Клиент vSphere перестает отвечать после модернизации vCenter Server 8.0 Update 3b «У вас нет прав на просмотр этого объекта, или он удален»

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Эта проблема может проявляться в виде различных симптомов, которые обычно возникают после длительного периода бездействия сеанса (1-2 часа)

  • После модернизации vCenter Server до версии 8.0.3.00200 работа vSphere Client становится нестабильной и истекает время ожидания сеанса.
  • Индикатор круга загрузки постоянно вращается.
  • Просмотр инвентаризации может завершиться сбоем с ошибками, такими как «У вас нет прав на просмотр этого объекта или он удален», как указано ниже.
    • При попытке входа в клиент кнопка входа может быть неактивна.
    • Аутентификация может завершиться ошибкой: При получении поставщиков удостоверений произошла ошибка

Cause

Эта проблема вызвана изменением поведения RECYCLE_FACADES по умолчанию в Tomcat в этом выпуске. 

Resolution

Эта проблема устранена в выпуске vCenter Server 8.0U 3c — ссылка на примечания к выпуску 
 

Чтобы обойти эту проблему, выполните следующие действия по отключению RECYCLE_FACADES.

  1. Войдите в vCenter Server с помощью SSH
     
  2. Создайте резервную копию файла catalina.properties.
     
    cp /usr/lib/vmware-vsphere-ui/server/conf/catalina.properties /root/catalina.properties.bak

     
  3. Выполните следующую команду, чтобы добавить строку в конец исходного файла catalina.properties, чтобы отключить RECYCLE_FACADES.
     
    echo "org.apache.catalina.connector.RECYCLE_FACADES=false" >> /usr/lib/vmware-vsphere-ui/server/conf/catalina.properties

     
  4. Перезапустите службу vsphere-ui с помощью следующей команды.
     
    service-control --restart vsphere-ui

Affected Products

Virtual Storage Integrator (VSI), VMware ESXi 8.x
Article Properties
Article Number: 000319177
Article Type: Solution
Last Modified: 11 May 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.