VxRail: vSphere Client holder op med at svare efter opgradering af vCenter Server 8.0 Update 3b

Summary: vSphere Client reagerer ikke efter opgradering af vCenter Server 8.0 Update 3b "Du har ingen rettigheder til at se dette objekt, eller det er slettet"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dette problem kan vise sig i forskellige symptomer, som normalt vil opstå efter en længere periode med inaktivitet i sessionen (1-2 timer)

  • Efter opgradering af vCenter Server til 8.0.3.00200 bliver vSphere-klienten ustabil, og der opstår sessionstimeouts.
  • Indikatoren for lastecirkel drejer konstant.
  • Gennemse oversigten mislykkes muligvis med fejl som "Du har ingen privilegier til at se dette objekt, eller det er slettet" som følger,
    • Når du forsøger at logge på klienten, kan loginknappen være nedtonet.
    • Godkendelse mislykkes muligvis med følgende fejl: Der opstod en fejl under hentning af identitetsudbydere

Cause

Dette problem skyldes en ændring i standardfunktionsmåden for RECYCLE_FACADES i Tomcat i udgivelsen. 

Resolution

Problemeter løst i vCenter Server 8.0U 3c-versionen – link til produktbemærkninger 
 

Du kan løse problemet ved at følge nedenstående trin for at deaktivere RECYCLE_FACADES.

  1. Log på vCenter Server med SSH
     
  2. Opret en sikkerhedskopi af filen catalina.properties.
     
    cp /usr/lib/vmware-vsphere-ui/server/conf/catalina.properties /root/catalina.properties.bak

     
  3. Kør følgende kommando for at føje en linje til slutningen af den oprindelige catalina.properties-fil for at deaktivere RECYCLE_FACADES.
     
    echo "org.apache.catalina.connector.RECYCLE_FACADES=false" >> /usr/lib/vmware-vsphere-ui/server/conf/catalina.properties

     
  4. Genstart vsphere-ui-tjenesten med nedenstående kommando.
     
    service-control --restart vsphere-ui

Affected Products

Virtual Storage Integrator (VSI), VMware ESXi 8.x
Article Properties
Article Number: 000319177
Article Type: Solution
Last Modified: 11 May 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.