PPDM:SQL AppAware (VM Direct) 組態因代理和連接埠問題而失敗
Summary: 由於代理授權錯誤和網路連接埠限制,PowerProtect Data Manager (PPDM) 中的 SQL AppAware (VM Direct) 組態失敗。此問題通常是因為 PPDM 伺服器、目標虛擬機器及 Data Domain 系統之間的通訊遭到封鎖所造成。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
受影響的產品:
- PowerProtect Data Manager (PPDM)
症狀:
- SQL AppAware (VM Direct) 組態在設定期間失敗
- PPDM 中的錯誤:
-
Unable to register PowerProtect Agent Service. HTTPSConnectionPool(host='PPDM-server-ip', port=8443): Max retries exceeded with url: /api/v2/adm/agentRegistration (Caused by ProxyError('Cannot connect to proxy.', OSError('Tunnel connection failed: 407 Proxy Authorization Required')))
-
- vProxy 代理程式安裝失敗,並顯示:
-
Command 'C:\Windows\system32\msiexec.exe' terminated with exit code 1601
-
Cause
- 連接埠 7000 無法從 PPDM 伺服器連線至目標虛擬機器
- 缺少在虛擬機器內部署 SQL AppAware 代理程式的系統管理員權限
- 代理組態會封鎖連出通訊,導致 407 需要代理授權 錯誤
Resolution
若要解決此問題:
-
確保網路連線能力:
- 開啟從 VM 連接至 PPDM 伺服器的連接埠 8443
- 開啟從虛擬機器到 Data Domain 系統的連接埠 111、2049 和 2052
- 開啟從 PPDM 至目標虛擬機器的連接埠 7000
-
在 SQL AppAware 設定期間使用 FLR 代理程式的系統管理員登入資料
-
檢查代理設定 ,確保 PPDM 伺服器可進行外部通訊,而不會發生代理驗證錯誤
注意:VM Direct 執行塊級備份,而 SQL AppAware 使用內部代理進行 SQL 事務日誌備份。這兩個元件都需要與 PPDM 和 DD 系統進行不間斷的通訊。
Affected Products
PowerProtect Data Manager, PowerProtect App Direct, PowerProtect SoftwareArticle Properties
Article Number: 000321643
Article Type: Solution
Last Modified: 03 Oct 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.