Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Unable to Select External Monitor Connected to Dell Universal (D6000 Series) Dock as Main Display

Summary: How to resolve an issue with the external monitor that is connected to the Dell Universal (D6000 series) docking station not showing as the main display.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

No symptom information.

Cause

No cause information.

Resolution

Dell Universal (D6000 Series) Docking Station External Monitor Issue

An issue may occur when trying to set the external monitor as the main display when it is connected to the Dell Universal (D6000 series) Dock. Only the laptop's LCD display can be set to the main display. The external monitor will not show as a choice in the Intel Graphics application. This issue was reported on the Latitude 7480 laptop with Windows 10 installed and using the integrated Intel 620 HD graphics adapter, but may appear on other Dell laptops using a similar configuration.

To resolve the issue, download and install the latest DisplayLink USB Graphics Software for Windows from the following location: DisplayLink Windows Driver DownloadsSLN307055_en_US__1iC_External_Link_BD_v1. After installing the software, reboot the computer and select the external monitor as the main display in Windows display settings.

It is also recommended that you install the latest graphics driver and BIOS update for your computer from Dell Support/Drivers and downloads, under the Video and BIOS categories.

Other Reference:

Article Properties


Affected Product

Dell Universal Dock D6000

Last Published Date

03 Dec 2021

Version

6

Article Type

Solution