Ethernet Network Does Not Work on the Dell WD19S, WD19DCS, and WD22TB4 Docks
Summary: The following article provides information about an Ethernet network problem on some of the Dell USB Type-C docks. This happens on the Dell WD19S, WD19DCS, and WD22TB4 docks.
Symptoms
Ethernet controller driver missing from Device Manager for the WD19S, WD19DCS, and WD22TB4 Dell docks
Users of mobile devices such as laptops and tablets may experience their Ethernet network connection dropping when they connect to one of the following Dell Docks:
- Dell Dock (WD19S)
- Dell Performance Dock (WD19DCS)
- Dell Thunderbolt Dock (WD22TB4)
The Device Manager utility does not list the Local Area Network (LAN) device on laptops and tablets running the Windows operating system: (Realtek Gigabit Ethernet (GBE) Family Controller)
| Dock Ethernet Controller Missing | Dock Ethernet Controller Present |
|---|---|
![]() Figure.1 |
![]() Figure.2 |
Cause
This section is not relevant to this article.
Resolution
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Running the latest Realtek USB Ethernet firmware update on the device resolves the issue. To download and install the latest firmware utility, follow the steps listed below:
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Browse to the driver page for the appropriate docking station:
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Select the Operating System that is running on the Dell laptop or tablet.
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Under Category, leave it as All.
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Locate the latest Realtek USB GBE Ethernet Controller Firmware Utility. (Version 1.2, A02.)
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Click Download and save the file to your laptop or tablet.
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Open File Explorer and browse to the download folder where it saves the download file.
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Extract the download DellFW_UPGRADE_UTILITY_v1.2.zip setup file and follow the instructions in the downloaded Dell Dock LAN repair tool installation guide_v1.2.pdf file to complete the installation process.
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Disconnect the USB Type-C docking cable from the laptop or mobile device. (Do Not Remove the AC Adapter from the docking station.)
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Wait at least 15 seconds after disconnecting the docking cable before going to step three.
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Reconnect the docking cable to the laptop or mobile device.
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Open the Device Manager application from the search function of the start menu.
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Is the Ethernet device from the docking station visible in the device manager window?
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No, it is not visible. Run through steps one to three again.
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Yes, it is visible. Run through the firmware update again.
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