SourceOne Email Management - ExAsIdxObj.exe process hangs when processing index transactions files

Summary: SourceOne Email Management - ExAsIdxObj.exe process hangs when processing index transactions files

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Symptoms



When processing index transaction files, the SourceOne Email Management ExAsIdxObj.exe process may hang and cause a backlog in the Index\DropDir folder.

The ExAsidxObj.exe.log trace log file on the Native Archive server performing the indexing will show the following failure:

Opening stream for file <Drive>:\EMC SourceOne IndexWork\<ArchiveFOlder_YearMonth_IndexSet>\UTF8\<MsgID>.dir\<AttachmentName.Extension>

Stream type returned is [51]

Opening Stream

After this the following entry will increment upwards in milliseconds until it reaches 20 minutes (approx. 1200000 milliseconds):

Longest running counter is owned by thread <Thread Number> and has been running for <Milliseconds>

Enter Stop Indexing Component: \\<IndexShare>\<Archive Folder>\<YearMonth>\<IndexNum>

Stop Indexing Component Found Running Thread: \\<IndexShare>\<Archive Folder>\<YearMonth>\<IndexNum>

Setting terminate thread event

The thread never terminates and the ExAsIdxObj.exe process continues to sit in the Task Manager.


This causes a backlog in the Index\DropDir folder and the MessageCenter\Unpack_Area which in turn causes a decrease in available Free Disk Space.
 

Cause

This problem is caused by a software defect cited under SDR60784.

This issue is caused by ISYS binaries included in SourceOne 7.2 SP4 Hotfix 1 and Hotfix 2:

SourceOne Email Management 7.2 SP4 Hot Fix 1 (7.24.4105) ISYS Version: 11.3.0.2322 SourceOne Email Management 7.2 SP4 Hot Fix 2 (7.24.4164) ISYS Version: 11.3.0.2400 NOTE: This was the original release of HFB1 that has been removed SourceOne Email Management 7.2 SP4 Hot Fix 2 (7.24.4164) ISYS Version: none supplied NOTE: This is a susequent release of HFB2 that did not supply ISYS binaries



Resolution

This issue is resolved in Hotfix Bundles or Service Pack versions on or higher than 7.2.5.5133.
Hotfix Bundles and Service Pack kits are available for download via https://Support.emc.com,
Please note, Hotfixes are only available for the most current patch or Service Pack versions of the product that were available when this problem was resolved.
*** Please note that When installing Hot Fix Bundles (HFBs) they must be installed in order for ALL fixes to be correctly applied.
*** Please note that it is always recommended to upgrade to the latest version of the SourceOne release, service pack and Hot Fix Bundle to ensure all currently resolved issues will be fixed including the issue as stated above.

To resolve this issue please upgrade to 7.2.5 GA and immediately install the Hotfix Bundle 1. This will ensure that the ISYS files version 11.4.0.2581 are installed.
Article Properties
Article Number: 000167674
Article Type: Solution
Last Modified: 23 Jul 2025
Version:  3
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