Avamar: Backup List Is Taking a Lot of Time after Applying 19.9 Mcs Hotfix 338748

Summary: After applying 19.9 Management Console Server (MCS) hotfix 338748, it is taking a lot of time to retrieve the backups, and sometimes it is timed out.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Confirm that the current Avamar version is 19.9 with hotfix 338748:

admin@avamar-server:~/>: mcserver.sh --version
  version:              19.9.0-78_HF338748
  build date:           Aug 22 2023 12:55:54
  PostgreSQL version:   postgres (PostgreSQL) 10.23
  db schema version:    19.8.0.1
  views schema version: 7.5.0.5
admin@avamar-server:~/>:

In the following example, the Avamar client has 14 local backups and 14 remote backups.

During the backup retrieve in Avamar User Interface (AUI) or Avamar Administrator UI, the mcserver log shows the following messages: 

getImmutableBackupStatus
getGovernanceModeStatus
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>: grep "195983] com.avamar.mc.dpn.DPNProxyService.get" mcserver.log.0
12/21-04:43:55.00773 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:55.00773 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:55.00892 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
12/21-04:43:55.00892 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
...
...
...
12/21-04:43:59.00055 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:59.00055 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:59.00174 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
12/21-04:43:59.00174 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>:

admin@avamar-server:/usr/local/avamar/var/mc/server_log/>: grep "195983] com.avamar.mc.dpn.DPNProxyService.get" mcserver.log.0 | wc -l
56
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>:

In some environment it was found 3898 events:

admin@avamar-server:/usr/local/avamar/var/mc/server_log/>: grep "12556] com.avamar.mc.dpn.DPNProxyService.get" mcserver.log.1 | wc -l
3898
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>:

Another symptom that can occur is some VMware image backups failing with the error code 30902 (Activity failed - client was given a workorder but did not acknowledge its receipt.)

The mcdb shows the error after the hotfix 338748 was applied (in this example, after 2024-02-06):

avmar-mcdb=# select recorded_date,count(status_code_summary) from v_activities_2 where recorded_date >= '2023-01-01%' and status_code_summary like '%client was given a workorder but did not acknowledge its receipt%' group by recorded_date order by recorded_date asc;
recorded_date | count
---------------+-------
2024-02-06    |     2
2024-02-07    |     9
2024-02-08    |     2
2024-02-11    |     1
2024-02-12    |    10

Cause

Engineering determined as a problem and Avamar Defect AVAMAR-39020 - After applying HF338748, it takes time to list backup was opened to address this problem.

Resolution

Download the latest 19.9 MCS hotfix. Until this date (May 30), the latest MCS hotfix version is 338802.

To download the hotfix, see the section "Looking for a Hotfix with its number" in the article Avamar: How to find and download a product hotfix, patch, install or upgrade package from the Dell Support website.

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000220715
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  6
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