Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Utilisation des journaux Windows pour résoudre les problèmes de connexion sans fil rencontrés uniquement sur les sites des clients

Summary: Cet article fournit des informations sur la capture d’un journal de suivi d’événements (ETL). Il inclut l’ETL et d’autres fichiers qui peuvent aider Dell dans le dépannage des problèmes sans fil rencontrés uniquement sur les sites du client. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Le système d’exploitation Windows dispose de nombreux journaux qui peuvent être utiles lors de l’analyse des problèmes de connexion sans fil sur le site du client. Surtout lorsque ces problèmes ne peuvent pas être répliqués dans d’autres environnements réseau.

Cause

Localisation, création et exportation des logs

Logs qui existent déjà à partir des tests précédents :

  1. Avant de rencontrer l’ordinateur, des journaux peuvent avoir été créés et peuvent s’avérer utiles. Le WLANAutoconfig.log fichier dans l’Observateur d’événements (s’il n’est pas déjà compilé dans un fichier CAB) est disponible et enregistré manuellement dans l’Observateur d’événements Windows :
    1. Dans Observateur d’événements, accédez à Applications et journaux de service.
    2. Accédez à Microsoft.
    3. Accédez à Windows.
    4. Ouvrez ensuite le Wlan-autoconfig dossier.
  2. Le NETSH script ci-dessous renvoie au dossier C :\wlogs  :

WLAN-autoconfig Consignation des diagnostics

Vous pouvez activer le WLAN-autoconfig journal de diagnostic sur le système en cours de test (SUT) avant les tests futurs. Cela peut vous aider avec des messages de journal plus explicites. Suivez les instructions ci-dessous.

Pour activer le journal de diagnostic :

  1. Ouvrez l’Observateur d’événements et accédez à :
    1. Journaux d’applications et de services
    2. Puis , Microsoft
    3. Puis , Windows
    4. Puis Wlan-Autoconfig
  2. Cliquez avec le bouton droit de la souris sur le Wlan-Autoconfig dossier.
  3. Ensuite, sélectionnez Afficher.
  4. Afficher les journaux analytiques et de débogage .
  5. Le journal de diagnostic s’affiche dans le dossier Autoconfig.
  6. Cliquez avec le bouton droit de la souris sur le journal de diagnostic et choisissez : Activer le journal

Resolution

Remarque : Il y a une mise en garde. Ce journal doit être enregistré manuellement à partir de l’observateur d’événements afin de le partager avec Dell après le test. Il se peut qu’il ne se trouve pas automatiquement dans le dossier cab de NETSH sortie.

Netsh texte du script pour référence : (Copiez le texte ci-dessous, collez-le dans un bloc-notes et enregistrez le fichier sous ETL.BAT)

@echo off

rem PASTE THIS SCRIPT INTO NOTEPAD AND SAVE AS A .BAT FILE. RT CLICK THE FILE AND RUN AS ADMINISTRATOR.

rem DO NOT CREATE DIRECTORY IF IT ALREADY EXISTS
if exist c:\wlogs goto SKIPMKDIR
mkdir c:\wlogs
:SKIPMKDIR

rem BEGIN TRACE
netsh ras set tracing * enable

rem BUNDY, I WOULD LIKE TO DYNAMICALLY GENERATE THE FILENAME wlan001.etl TO AVOID WRITING OVER PREVIOUS LOGS
SET file1=1
IF EXIST c:\wlogs\wlan%file1%.etl GOTO nextlog
netsh trace start scenario=wlan tracefile=c:\wlogs\wlan1.etl capture=yes persistent=yes maxsize=250 report=yes
filemode=append
GOTO filedone
:nextlog
SET /A "file1+=1" IF EXIST c:\wlogs\wlan%file1%.etl GOTO nextlog
netsh trace start scenario=wlan tracefile=c:\wlogs\wlan%file1%.etl capture=yes persistent=yes maxsize=250 report=yes
filemode=append

:filedone
rem DISPLAY PROMPT TO PRESS ANY KEY TO STOP THE CAPTURE
set /p =Press any key to stop the capture. < nul
pause > nul

rem STOP TRACE
netsh trace stop

rem DISPLAY RESULTS AND PROMPT TO HIT ANY KEY BEFORE ENDING
pause

Article Properties


Affected Product

Desktops & All-in-Ones, Laptops

Last Published Date

10 Oct 2023

Version

5

Article Type

Solution