NetWorker: Solución de problemas de eventos de espera de medios: en espera de 1 volumen con capacidad de escritura o ningún dispositivo coincidente
Summary: NetWorker: Solución de problemas de eventos de espera de medios: en espera de 1 volumen con capacidad de escritura o ningún dispositivo coincidente
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Una operación de respaldo o clonación se realiza a través de NetWorker.
- Se observan los siguientes mensajes de error.
- En espera de <la cantidad> de volúmenes con capacidad de escritura para respaldar la familia> del pool "pool>"<< en el <host>
- No hay dispositivos que coincidan; Compruebe los nodos, los dispositivos o los pools de almacenamiento.
- Estos mensajes se pueden encontrar a través de:
- NetWorker Management Console (NMC): Políticas > de monitoreo >Policy_Name >orkflow_Name >ction_Name > Mostrar detalles>, Sesión fallida, Mostrar mensajes>, > Obtener registro completo.
- Para los problemas de "Esperando volumen con capacidad de escritura", este mensaje también aparece en la ventana Alertas de NMC.
- El daemon.raw del servidor NetWorker Server también informa estos mensajes.
- Modo de empleo nsr_render_log: NetWorker: Cómo utilizar nsr_render_log
- Cómo habilitar la representación .raw en tiempo real: NetWorker: Cómo representar automáticamente daemon.raw a daemon.log en tiempo real
- NetWorker Management Console (NMC): Políticas > de monitoreo >Policy_Name >orkflow_Name >ction_Name > Mostrar detalles>, Sesión fallida, Mostrar mensajes>, > Obtener registro completo.
Cause
Las alertas anteriores se producen cuando NetWorker no puede encontrar ningún volumen adecuado en el que escribir un respaldo. Se pueden generar por una o más de las siguientes razones mencionadas en la sección Resolución.
Resolution
Definiciones de acciones
La configuración de la acción del flujo de trabajo de > la política > y los pools de medios deben estar configurados correctamente:
Pool de destino
La propiedad Pool de destino de la acción define el pool al que se envían los datos. Un pool es una recopilación de volúmenes en los que NetWorker escribe datos.
El atributo pool se configura en NMC. Seleccione un flujo de trabajo dentro de una política y revise la acción pertinente. El respaldo se envía al pool que se define en el parámetro de acción "Pool de destino".
NOTA: Si "Client Override Behavior" en la acción se establece en "Client Can Override", el valor "Pool" del cliente se toma en cuenta como la primera prioridad.
El pool al que se envían los datos debe contener un volumen disponible. Puede ver la lista de volúmenes y sus pools en, por ejemplo, Volúmenes de disco de medios > .
Para ver un ejemplo específico, consulte este artículo:
Nodo de almacenamiento de destino
El atributo Nodo de almacenamiento de destino de la acción del flujo de trabajo se debe configurar correctamente. Este campo especifica el nombre de host del nodo de almacenamiento que tiene los dispositivos que reciben los datos de respaldo. De manera predeterminada, aparece el servidor NetWorker Server. Para seleccionar un nodo de almacenamiento remoto, haga clic en el botón Edit ubicado a la derecha del campo y seleccione cada nodo de almacenamiento necesario.
NOTA: Si "Client Override Behavior" en la acción se configura en "Client Can Override", el nodo de almacenamiento definido en el parámetro de cliente denominado "Storage Nodes" en el cliente "Globals" (2 de 2) se utiliza como prioridad. Ver > el modo de diagnóstico debe estar habilitado en NMC para ver el campo Nodos de almacenamiento. De manera predeterminada, se define el nodo de almacenamiento del servidor NetWorker Server (nsrserverhost).
Asegúrese de que haya volúmenes disponibles (montados) en los dispositivos del nodo de almacenamiento que seleccionó. Puede comprobar esto en NMC, en Dispositivos Dispositivos > .
NOTA: Si la columna "Nombre del volumen" está vacía, el dispositivo no está montado. La columna "Volume Pool" no se muestra de manera predeterminada, pero se puede agregar.
Para ver ejemplos específicos, consulte este artículo:
Propiedades del cliente
Si el recurso de cliente de NetWorker tiene seleccionado "respaldo de Data Domain", debe haber un volumen de Data Domain disponible en el pool seleccionado.
NOTA: Ver > el modo de diagnóstico debe estar habilitado en NMC para ver las opciones de Data Domain de deduplicación.
Respaldos de bootstrap
El saveset de bootstrap de NetWorker Server solo se puede guardar en un volumen montado mediante el nodo de almacenamiento integrado de NetWorker Server (por diseño). Es decir, los savesets de bootstrap de NetWorker Server no se pueden guardar en dispositivos remotos (rd=storagenode_name:device_name).
Para ver un ejemplo específico, consulte estos artículos:
- Artículo de la base de conocimientos 39833 El respaldo de la base de datos del servidor NMC falla con "no hay dispositivos coincidentes para guardar el cliente"
Propiedades del pool
El dispositivo especificado en el atributo Devices del pool de destino debe tener la ruta correcta.
Los dispositivos seleccionados se deben montar en Dispositivos Dispositivos > :
NOTA: Si la columna "Nombre del volumen" está vacía, el dispositivo no está montado. La columna "Volume Pool" no se muestra de manera predeterminada, pero se puede agregar.
Resolución de nombres
También se deben verificar las resoluciones de nombres observadas con NetWorker Server, los nodos de almacenamiento, los clientes o los dispositivos.
Para ver ejemplos específicos, consulte estos artículos:
- 000041288, Solución de problemas de DNS y resolución de nombres
- 000004384, NetWorker: Cómo utilizar la validación de recursos de NetWorker nsradmin -C
Consideraciones de clonación
La clonación se debe configurar correctamente. NetWorker requiere dos o más dispositivos de almacenamiento para realizar una operación de clonación. Un dispositivo contiene el volumen con los datos originales y otro dispositivo contiene el volumen en el que NetWorker escribe los datos de clonación. El origen y el destino deben ser dos volúmenes diferentes. Cada volumen de clonación solo puede contener una instancia de un saveset clonado.
La clonación se puede configurar de varias maneras diferentes en NetWorker. Una manera común es configurar un grupo de NetWorker de tipo "Consulta de saveset". Para esto, el asistente de acción de política para el flujo de trabajo que se ha asociado con el grupo se puede utilizar para definir el 'Nodo de almacenamiento de destino' y el 'Pool de destino'. Esto decide dónde se escriben exactamente estos datos de clonación. Debe haber volúmenes de NetWorker disponibles en este pool que utilicen este nodo de almacenamiento que aún no tenga una copia de esta instancia de saveset.
Como alternativa, se puede agregar una acción de clonación después de una acción de respaldo para clonar los savesets respaldados por la acción anterior. El asistente de acción de política se utiliza para definir dónde se deben escribir los datos de clonación.
Si no hay ningún nodo de almacenamiento de destino definido en la acción del flujo de trabajo, el nodo de almacenamiento en el que se escriben los datos de clonación depende de los nodos de almacenamiento enumerados en el campo "Clone storage nodes" para el nodo de almacenamiento de origen o, si está en blanco, el nodo de almacenamiento de NetWorker Server. Este valor se define en las propiedades de la pestaña "Configuration" del recurso del nodo de almacenamiento. Los datos clonados que se originan en este nodo de almacenamiento se dirigen al primer nodo de almacenamiento que tenga un dispositivo habilitado y un demonio de medios funcional (nsrmmd).
Dispositivos de cinta
Los problemas del dispositivo de cinta hacen que NetWorker no pueda escribir en el dispositivo de destino.
Dispositivos AFTD
El dispositivo de tipo de archivo avanzado (AFTD) de NetWorker no funciona según lo esperado:
Additional Information
Affected Products
NetWorkerProducts
NetWorker, NetWorker SeriesArticle Properties
Article Number: 000173177
Article Type: Solution
Last Modified: 05 Aug 2025
Version: 10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.
