Cloud Disaster Recovery Add-on (CDRA) fails to deploy

Summary: Cloud Disaster Recovery Add-on (CDRA) fails to deploy when a user is part of an organization with a Service Control Policies (SCP) configured.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Deployments which are using organizational SCP configured user-accounts have restrictions set that can prevent successful configuration of CDRA when it tries to query AWS and check for IAM policy permission or roles.

 

Cause

As a result of restrictions configured from using an organization SCP enabled account, the deployment process fails when it tries to check for 'verifyRolePriviligesForActions' as seen below in log excerpt:

DEBUG [2020-07-16 18:04:33,463] [main] [CdrRole:verifyRolePrivilegesForActions:272]: verifyRolePrivilegesForActions for user DellEMC-cdr-dr-vmc-cdrs-user-01
ERROR [2020-07-16 18:04:33,605] [main] [CdrRole:verifyRolePrivilegesForActions:300]: Insufficient privileges.Missing Permissions for: s3:*, ec2:*, cloudwatch:*, cloudformation:*, rds:*, sqs:*, ses:SendEmail, ses:SendRawEmail, ses:Verify*.
ERROR [2020-07-16 18:04:33,605] [main] [CloudManager:init:280]: Insufficient privileges.Missing Permissions for: s3:*, ec2:*, cloudwatch:*, cloudformation:*, rds:*, sqs:*, ses:SendEmail, ses:SendRawEmail, ses:Verify*.
java.lang.RuntimeException: Insufficient privileges.Missing Permissions for: s3:*, ec2:*, cloudwatch:*, cloudformation:*, rds:*, sqs:*, ses:SendEmail, ses:SendRawEmail, ses:Verify*.

 

Resolution

As a workaround, configure SCP account so that it does not restrict the role being used to deploy CDRS.

 

Affected Products

Avamar, PowerProtect Data Protection Appliance, Cloud Disaster Recovery, PowerProtect Software
Article Properties
Article Number: 000183021
Article Type: Solution
Last Modified: 16 Oct 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.