PowerProtect | DDBMA standalone back-up van SQL Always On database (AAG) mislukt

Summary: Data Domain DD Boost voor Microsoft Applications (DDBMA) standalone back-up van SQL Always On Availability Group (AAG) database mislukt

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Back-ups lijken met succes te zijn uitgevoerd, maar de opgeslagen procedure (master.dbo.emc_run_backup) meldt een fout met de volgende gebeurtenissen:

Foutmelding:

Successfully converted from group id to AG name.

149283:ddbmsqlsv: Start secondary backup job failed. host: <hostname>. error: Setting notification event failed on host: <hostname>.
85942:ddbmsqlsv: Stopping Federated backup - No jobs were started successfully. Unable to complete the federated backup.


 

Cause

De SQL Server Agent-taak wordt uitgevoerd onder de context van de gebruiker die is gekoppeld aan de SQL Server Agent-service. Dit gebruikersaccount had alle benodigde machtigingen (lokaal beheerder op SQL Server, volledige Windows Management Instrumentation (WMI)-machtigingen volgens de Microsoft App Agent-handleiding). De back-up werkt ook wanneer deze wordt uitgevoerd vanaf de SQL Server Management Studio (SSMS)-plug-in die is aangemeld met deze gebruiker (gekoppeld aan de SQL Server Agent-service).

Wanneer de back-upgebruiker geen lokale beheerder is, beschikt deze niet over de vereisteWMI-bevoegdheden. Dit verklaart waarom back-ups slagen in de gebruikersinterface die gebruikmaakt van het account van de aangemelde gebruiker, maar mislukken in SQL, dat gebruikmaakt van het SQL-serviceaccount.

Resolution

Controleer of de gebruiker lid is van de lokale beheerdersgroep en voeg indien nodig het SQL-serviceaccount toe. Verifieer Aanmelden als een batchtaak of Aanmelden als een servicebevoegdheden , meestal verleend vanuit de lokale beheerdersstatus; Handmatig toevoegen indien afwezig. Als de problemen aanhouden, start u de SQL-service opnieuw of start u de server opnieuw op om de lokale beheerdersbevoegdheden volledig toe te passen.

Affected Products

PowerProtect App Direct, PowerProtect Software
Article Properties
Article Number: 000192006
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.