PowerStore: Upgrade fails due to hardware issues, and node goes into service mode
Summary: A PowerStoreOS upgrade fails and one of the nodes ends up in service mode.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
A PowerStoreOS upgrade fails, and a node goes into service mode.
After close inspection, a hardware fault is identified. Depending on the faulted component, it is normal and expected that the node goes into service mode. This is expected behavior when, for example, a memory DIMM module is faulted.
The service mode status can be seen from the PowerStore Manager user interface (UI), and the ssh session on the affected node presents this message:
The command svc_diag list --hardware --sub_options fault_status can be used to narrow down the faulted component.
If this output is ambiguous or shows multiple faulted parts, check the SEL logs as well:
svc_diag list --hardware --sub_options sel
After close inspection, a hardware fault is identified. Depending on the faulted component, it is normal and expected that the node goes into service mode. This is expected behavior when, for example, a memory DIMM module is faulted.
The service mode status can be seen from the PowerStore Manager user interface (UI), and the ssh session on the affected node presents this message:
*** WARNING *** This Node is currently in Service Mode *** WARNING *** |
The command svc_diag list --hardware --sub_options fault_status can be used to narrow down the faulted component.
If this output is ambiguous or shows multiple faulted parts, check the SEL logs as well:
svc_diag list --hardware --sub_options sel
Cause
This is expected behavior if one of the critical node components fails during the upgrade, such as a memory DIMM module for example.
Resolution
The faulted component should be replaced as soon as possible.
In order to fully and correctly identify the faulted component, contact Dell Technical Support or your Authorized Service Representative, and quote this knowledge base article ID.
In order to fully and correctly identify the faulted component, contact Dell Technical Support or your Authorized Service Representative, and quote this knowledge base article ID.
Additional Information
Once the node is booted back in normal mode after the replacement, the upgrade should resume. If not, it can be resumed from the PowerStore Manager UI.
If there are other upgrade issues after the replacement, contact Dell Technical Support or your Authorized Service Representative, and quote this knowledge base article ID.
If there are other upgrade issues after the replacement, contact Dell Technical Support or your Authorized Service Representative, and quote this knowledge base article ID.
Affected Products
PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000TProducts
PowerStore 9000X, PowerStore 9000TArticle Properties
Article Number: 000198337
Article Type: Solution
Last Modified: 27 Feb 2023
Version: 2
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