NMC Installation Fails with Error "Unable to Verify Authentication Server's Hostname or Port"

Summary: NMC installation fails on a Windows host with error: Unable to verify Authentication Server's hostname or port.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • The NetWorker Management Console (NMC) installation fails on a Windows host with an Authentication failure message.
Authentication failure message appears during NMC installation on Windows.
Figure 1: Authentication failure message appears during NMC installation on Windows.
  • The NMC server is installed on a Windows host separate from the NetWorker server.
  • The NetWorker authentication service is up and running.
  • Port 9090 is open.
nsrports -t NetWorker_ServerName -p 9090

Cause

The NMC installation negotiates with the NetWorker authentication service over TLS earlier than version 1.2.

Resolution

Perform the following on the NetWorker server:
  1. Make a backup copy of:
C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\conf\server.xml.
  1. Edit the server.xml file and look for the string.
sslEnabledProtocols="TLSv1.2"
 Change the string to
sslEnabledProtocols="TLSv1.2, TLSv1.1, TLSv1"
NOTE: These changes are temporary and are only being done to complete the NMC installation. They can be reverted once the NMC installation has been completed.
  1. Save the changes to the file.
  2. Restart the NetWorker service.
net stop nsrexecd /y 
net start nsrd
  1. Install NetWorker and NMC on the NMC server. This time the prompt to install the certificate should appear.
  2. Add the certificate to the Root Trusted certificate list. Continue until the installation completes.
After the installation finishes, revert to the original copy of server.xml. A NetWorker service restart is required for the changes to take effect.

Additional Information

Affected Products

NetWorker Family
Article Properties
Article Number: 000219009
Article Type: Solution
Last Modified: 23 Jul 2024
Version:  4
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