Precision 5860 or 7960 Tower USB Devices Fail When Connected
Summary: This article provides information about the USB devices failing or not working on the Precision 5860 or 7960 Tower.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
USB devices such as keyboard, headset, mouse, or camera connected to Precision Workstations may fail to connect. Due to the symptoms, it seems as if the computer stops responding. The issue occurs on both front and back ports, while in use within Windows. Usually, the only remedy is to reboot the computer.
Affected Platforms:
- Precision 5860 Tower
- Precision 7960 Tower
Cause
This is due to the issue with the chipset, not specific to Dell.
Resolution
Updating to BIOS version 2.4.1 or later on the computer resolves the issue. To download and install the BIOS, reference BIOS Update Guide.
Affected Products
Precision 5860 Tower, Precision 7960 TowerArticle Properties
Article Number: 000222611
Article Type: Solution
Last Modified: 13 Nov 2025
Version: 8
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