NetWorker: Azure-abonnementer mangler efter ændring af NetWorker Datazone-adgangssætning.

Summary: Når du har tilføjet eller opdateret NetWorker-"Datazone Pass Phrase", er tidligere konfigurerede "Azure-abonnementsressourcer" ikke længere synlige for NetWorker. Dette

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker-serverens "Datazone Pass Phrase" er for nylig blevet ændret. 
Følgende meddelelser kan ses på NetWorker-serverens daemon.raw:

98582 MM/DD/YY HH:mm:SS  nsrd NSR info Permission allowed, user 'USER_PATH' on 'HOST' has 'Change Security Settings' privilege to change datazone pass phrase.
53115 MM/DD/YY HH:mm:SS  nsrd NSR info Successfully modified Resource type: 'NSR', Resource name: 'SERVER_NAME' for Attribute: 'datazone pass phrase' by user: 'USER_PATH' on host: 'HOST'

NetWorker-serveren er konfigureret med Azure-abonnementer. Når Datazone Pass Phrase er blevet ændret, vises Azure-abonnementerne ikke længere i NetWorker-webbrugergrænsefladen (NWUI):

NWUI viser Ingen Azure-abonnementer

Ikonet daemon.raw logfører følgende meddelelse fra, hvornår NWUI forsøgte at få vist Azure-abonnementerne:

101059 MM/DD/YY HH:mm:SS  nsrd NSR critical Unable to decrypt data: error:1C800064:Provider routines::bad decrypt
101059 MM/DD/YY HH:mm:SS  nsrd NSR critical Unable to decrypt data: error:1C800064:Provider routines::bad decrypt

Azure Backups mislykkes med følgende fejl:

  • Linux: /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME/ACTION_JOBID_logs/JOBID.log
  • Windows (standard):  C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME\ACTION_JOBID_logs\JOBID.log
208101:nsrazure_save: azure_lib_init: error while fetching subscription details.
207815:nsrazure_save: Azure subscription resource AZURE_SUBSCRIPTION_RESOURCE_NAME does not exists.

Azure-abonnementet findes stadig i NetWorker Server Resource Database (NSRDB):

azure-nve:~ # nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> print type: nsr azure subscription
                        type: NSR Azure Subscription;
                        name: AZURE_SUBSCRIPTION_RESOURCE_NAME;
                     comment: ;
                   tenant id: 94XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX2dd;
             subscription id: 50XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXfe3;
                   client id: 3bXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX38b;
               client secret: *******;
                    endpoint: management.azure.com;
                     command: nsrazure_discovery;
nsradmin> quit

Cause

Dette spørgsmål er blevet rejst over for NetWorker-teknik.

Resolution

Denne artikel opdateres, når der er fundet en løsning. Indtil videre kan en af følgende løsninger bruges.

Løsning One:

Hvis den forrige Datazone-adgangssætning er kendt, skal du sætte adgangssætningen tilbage til dens gamle værdi. Hvis der ikke tidligere har været et Datazone-adgangsudtryk , skal du fjerne adgangssætningen.


Datazone Pass Phrase kan indstilles på følgende placering i enten NetWorker Management Console (NMC) eller NetWorker Web User Interface (NWUI): Server –>Serveregenskaber –>Konfiguration –>Datazoneadgangssætning.


Alternativt kan den indstilles fra en nsradmin Prompten: 

azure-nve:~ # nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> . type: nsr
Current query set
nsradmin> update datazone pass phrase: OLD_PASS_PHRASE
        datazone pass phrase: OLD_PASS_PHRASE;
Update? y
updated resource id 3.0.53.124.0.0.0.0.233.61.161.103.10.164.158.89(789)
nsradmin> q

Azure-abonnementet bliver synligt i NWUI igen, og sikkerhedskopieringshandlingerne bør fungere normalt igen. 

BEMÆRK: Hvis du lod fanen Azure-abonnementer være åben i NWUI, mens du ændrede adgangssætningen, skal du gå til en anden fane i NWUI og derefter tilbage til fanen Azure-abonnementer, for at abonnementerne vises igen.

Løsning på to:

Hvis det gamle Datazone-adgangsudtryk ikke er kendt, skal du slette Azure-abonnementerne og føje dem til NetWorker igen. Dette gør det muligt for handlinger at fortsætte med at bruge den nye Datazone Pass-sætning.
Udfør følgende fra en administratorprompt eller rodshell på NetWorker-serveren.

  1. Få adgang til nsradmin Konsol: nsradmin
  2. Få oplysninger om Azure-abonnementerne: print type: nsr azure subscription
    VIGTIGT: Indsaml outputtet for hvert Azure-abonnement, og noter det i et tekstdokument. Du kan ikke få klienthemmeligheden. Hvis du ikke har gemt klienthemmeligheden, skal du oprette en ny klienthemmelighed fra Azure under: Appregistreringer ->Appnavn->Administrer - Certifikater og>hemmeligheder. Hvis du ikke har adgang til Azure, skal Azure-administratoren angive disse oplysninger.
  3. Slet Azure-abonnementerne: delete
  4. Du bliver bedt om at bekræfte sletningen for hvert Azure-abonnement. Indtast: y
  5. Log på NWUI, og opret Azure-abonnementerne igen ved hjælp af de oplysninger, der blev indsamlet i trin 2.
     

Når Azure-abonnementerne er oprettet igen, vises de i NWUI, og sikkerhedskopieringshandlingerne bør fungere normalt igen.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000420044
Article Type: Solution
Last Modified: 26 Jan 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.