NetWorker: Azure-tilaukset puuttuvat NetWorker-tietovyöhykkeen salasanalauseen muuttamisen jälkeen.

Summary: Kun NetWorkerin Datazone-salalause on lisätty tai päivitetty, aiemmin määritetyt Azure-tilausresurssit eivät enää näy NetWorkerille. Tämä

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker-palvelimen Datazone-salalause on hiljattain muutettu. 
Seuraavat viestit näkyvät NetWorker-palvelimen daemon.raw:

98582 MM/DD/YY HH:mm:SS  nsrd NSR info Permission allowed, user 'USER_PATH' on 'HOST' has 'Change Security Settings' privilege to change datazone pass phrase.
53115 MM/DD/YY HH:mm:SS  nsrd NSR info Successfully modified Resource type: 'NSR', Resource name: 'SERVER_NAME' for Attribute: 'datazone pass phrase' by user: 'USER_PATH' on host: 'HOST'

NetWorker-palvelimeen on määritetty Azure-tilaukset. Kun Datazonen salalausetta on muokattu, Azure-tilaukset eivät enää näy NetWorker Web User Interface (NWUI) -käyttöliittymässä:

NWUI ei näytä Azure-tilauksia

pikanäppäimellä daemon.raw kirjaa seuraavan sanoman siitä, kun NWUI yritti tarkastella Azure-tilauksia:

101059 MM/DD/YY HH:mm:SS  nsrd NSR critical Unable to decrypt data: error:1C800064:Provider routines::bad decrypt
101059 MM/DD/YY HH:mm:SS  nsrd NSR critical Unable to decrypt data: error:1C800064:Provider routines::bad decrypt

Azure-varmuuskopiointi epäonnistuu ja näyttöön tulee seuraava virhe:

  • Linux: /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME/ACTION_JOBID_logs/JOBID.log
  • Windows (oletus):  C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME\ACTION_JOBID_logs\JOBID.log
208101:nsrazure_save: azure_lib_init: error while fetching subscription details.
207815:nsrazure_save: Azure subscription resource AZURE_SUBSCRIPTION_RESOURCE_NAME does not exists.

Azure-tilaus on edelleen olemassa NetWorker Server Resource Databasessa (NSRDB):

azure-nve:~ # nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> print type: nsr azure subscription
                        type: NSR Azure Subscription;
                        name: AZURE_SUBSCRIPTION_RESOURCE_NAME;
                     comment: ;
                   tenant id: 94XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX2dd;
             subscription id: 50XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXfe3;
                   client id: 3bXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX38b;
               client secret: *******;
                    endpoint: management.azure.com;
                     command: nsrazure_discovery;
nsradmin> quit

Cause

Tämä ongelma on nostettu NetWorker-suunnittelulle.

Resolution

Tämä artikkeli päivitetään, kun ratkaisu on määritetty. Tällä hetkellä voidaan käyttää jotakin seuraavista kiertotavoista.

Vaihtoehtoinen menetelmä:

Jos aiempi Datazonen salalause on tiedossa, palauta salalause vanhaan arvoonsa. Jos Datazonen salalausetta ei ollut aiemmin, poista salalause.


Datazonen salasana voidaan määrittää seuraavaan sijaintiin joko NetWorker Management Consolessa (NMC) tai NetWorker Web User Interfacessa (NWUI): Server ->Palvelimen ominaisuudet ->Kokoonpano ->Datazonen salalause.


Vaihtoehtoisesti se voidaan asettaa nsradmin Nopeasti: 

azure-nve:~ # nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> . type: nsr
Current query set
nsradmin> update datazone pass phrase: OLD_PASS_PHRASE
        datazone pass phrase: OLD_PASS_PHRASE;
Update? y
updated resource id 3.0.53.124.0.0.0.0.233.61.161.103.10.164.158.89(789)
nsradmin> q

Azure-tilaus tulee jälleen näkyviin NWUI:ssa, ja varmuuskopiointitoimintojen pitäisi toimia jälleen normaalisti. 

HUOMAUTUS: Jos jätit Azure-tilaukset-välilehden auki NWUI:ssa salalausetta muutettaessa, sinun on siirryttävä toiseen välilehteen NWUI:ssa ja sitten takaisin Azure Subscriptions -välilehteen, jotta tilaukset tulevat uudelleen näkyviin.

Vaihtoehtoinen menetelmä kaksi:

Jos vanhaa Datazonen salalausetta ei tunneta, sinun on poistettava Azure-tilaukset ja lisättävä ne uudelleen NetWorkeriin. Näin toiminnot voivat jatkaa uuden Datazone Sala Phrase -lausekkeen käyttöä.
Tee seuraavat toimet järjestelmänvalvojakehotteessa tai NetWorker-palvelimen juuriliittymässä.

  1. Avaa nsradmin Konsoli: nsradmin
  2. Hae Azure-tilausten tiedot: print type: nsr azure subscription
    TÄRKEÄÄ: Kerää kunkin Azure-tilauksen tulos ja merkitse se tekstiasiakirjaan. Et voi saada asiakassalaisuutta. Jos asiakasohjelman salasanaa ei ole tallennettu, uusi asiakasohjelman salasana on luotava Azuresta kohdassa Sovelluksen rekisteröinnit ->sovelluksen nimi->hallinta ->varmenteet ja salaisuudet. Jos sinulla ei ole Azuren käyttöoikeutta, Azure-järjestelmänvalvojan on annettava nämä tiedot.
  3. Poista Azure-tilaukset: delete
  4. Sinua pyydetään vahvistamaan poisto jokaiselle Azure-tilaukselle. Kirjoita: y
  5. Kirjaudu NWUI:hin ja luo Azure-tilaukset uudelleen vaiheessa 2 kerättyjen tietojen avulla.
     

Kun Azure-tilaukset on luotu uudelleen, ne näkyvät NWUI:ssa, ja varmuuskopiointitoimintojen pitäisi toimia taas normaalisti.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000420044
Article Type: Solution
Last Modified: 27 Mar 2026
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.