NetWorker:NetWorkerデータゾーン パスフレーズを変更した後にAzureサブスクリプションが見つからない。

Summary: NetWorkerの「データゾーン パスフレーズ」を追加または更新すると、以前に構成した「Azureサブスクリプション」リソースはNetWorkerに表示されなくなります。この

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorkerサーバーの「データゾーン パスフレーズ」が最近変更されました。
NetWorkerサーバーの daemon.rawファイルに置き換えます。

98582 MM/DD/YY HH:mm:SS  nsrd NSR info Permission allowed, user 'USER_PATH' on 'HOST' has 'Change Security Settings' privilege to change datazone pass phrase.
53115 MM/DD/YY HH:mm:SS  nsrd NSR info Successfully modified Resource type: 'NSR', Resource name: 'SERVER_NAME' for Attribute: 'datazone pass phrase' by user: 'USER_PATH' on host: 'HOST'

NetWorkerサーバーがAzureサブスクリプションで構成されている。 データゾーン パスフレーズを変更すると、AzureサブスクリプションはNWUI(NetWorker Webユーザー インターフェイス)に表示されなくなります。

NWUIに「No Azure Subscriptions」と表示される

daemon.raw NWUIがAzureサブスクリプションを表示しようとしたときに、次のメッセージがログに記録されます。

101059 MM/DD/YY HH:mm:SS  nsrd NSR critical Unable to decrypt data: error:1C800064:Provider routines::bad decrypt
101059 MM/DD/YY HH:mm:SS  nsrd NSR critical Unable to decrypt data: error:1C800064:Provider routines::bad decrypt

Azureバックアップが次のエラーで失敗します。

  • Linuxの場合 /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME/ACTION_JOBID_logs/JOBID.log
  • Windows(デフォルト):  C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME\ACTION_JOBID_logs\JOBID.log
208101:nsrazure_save: azure_lib_init: error while fetching subscription details.
207815:nsrazure_save: Azure subscription resource AZURE_SUBSCRIPTION_RESOURCE_NAME does not exists.

Azureサブスクリプションは、NSRDB(NetWorkerサーバー リソース データベース)に引き続き存在します。

azure-nve:~ # nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> print type: nsr azure subscription
                        type: NSR Azure Subscription;
                        name: AZURE_SUBSCRIPTION_RESOURCE_NAME;
                     comment: ;
                   tenant id: 94XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX2dd;
             subscription id: 50XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXfe3;
                   client id: 3bXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXX38b;
               client secret: *******;
                    endpoint: management.azure.com;
                     command: nsrazure_discovery;
nsradmin> quit

Cause

この問題は、NetWorkerエンジニアリングに提起されています。

Resolution

解決策が判明すると、この記事は更新されます。とりあえず、以下のいずれかの回避策が考えられます。

回避策1:

以前の データゾーン パスフレーズ が既知である場合は、パスフレーズを古い値に戻します。以前にデータゾーン パスフレーズがない場合は、パスフレーズを削除します。


データゾーン パスフレーズは、NMC(NetWorker管理コンソール)またはNWUI(NetWorker Webユーザー インターフェイス)の次の場所に設定できます。server ->server properties ->configuration ->datazone pass phrase.


または、 nsradmin プロンプト: 

azure-nve:~ # nsradmin
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> . type: nsr
Current query set
nsradmin> update datazone pass phrase: OLD_PASS_PHRASE
        datazone pass phrase: OLD_PASS_PHRASE;
Update? y
updated resource id 3.0.53.124.0.0.0.0.233.61.161.103.10.164.158.89(789)
nsradmin> q

AzureサブスクリプションがNWUIに再び表示され、バックアップ操作が再び正常に機能するようになります。 

メモ: パスフレーズの変更中にNWUIで[Azureサブスクリプション]タブを開いたままにした場合、サブスクリプションを再表示するには、NWUIの別のタブに移動してから[Azureサブスクリプション]タブに戻る必要があります。

回避策2:

古い データゾーン パスフレーズ が不明な場合は、Azureサブスクリプションを削除してNetWorkerに再度追加する必要があります。これにより、操作では新しいデータゾーン パスフレーズを引き続き使用できます。
NetWorkerサーバーで、管理者プロンプトまたはrootシェルから次の操作を実行します。

  1. にアクセスします nsradmin コンソール: nsradmin
  2. Azureサブスクリプションの詳細を取得します。 print type: nsr azure subscription
    重要:各Azureサブスクリプションの出力を収集し、テキスト ドキュメントに書き留めます。クライアント シークレットを取得できません。クライアント シークレットが保存されていない場合は、次の場所でAzureから新しいクライアント シークレットを作成する必要があります。App Registrations ->App Name->Manage ->Certificates & Secrets.Azureへのアクセス権がない場合、Azure管理者はこれらの詳細を提供する必要があります。
  3. Azureサブスクリプションを削除します。 delete
  4. Azure サブスクリプションごとに削除を確認するように求められます。以下を入力します。 y
  5. NWUIにログインし、手順2で収集した情報を使用してAzureサブスクリプションを再作成します。
     

Azureサブスクリプションを再作成すると、NWUIに表示され、バックアップ操作が再び正常に機能するようになります。

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000420044
Article Type: Solution
Last Modified: 27 Mar 2026
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.