SQLのリストアが「データベースはすでに開いており、一度に1人のユーザーしか持てません」で失敗する

Summary: ユーザーがデータベースにアクセスするとSQLデータベースのリストアが失敗する問題を解決するためのナレッジベース(KB)記事。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SQLデータベースの元の場所へのリストアが、次のようなエラーで失敗します。
 

avsql Error <40258>: sqlconnectimpl_smo::get_database_data_names Microsoft.SqlServer.Management.Common.ExecutionFailureException: An exception occurred while executing a Transact-SQL statement or batch. ---> System.Data.SqlClient.SqlException: Database 'Avamar1' is already open and can only have one user at a time.



 

Cause

1人以上のユーザーまたは接続が、リストア先のデータベースにアクセスしています。データベースにアクセスするユーザーまたは接続がある場合、元のデータベースを上書きすることはできません。

Resolution

データベースのステータスをマルチユーザーモードからシングルユーザーモードに変更します。

SQL Server Management Studio の使用

データベースをシングル・ユーザー・モードに設定するには、次のようにします。

  1. オブジェクト エクスプローラーで、SQL Server データベース エンジンのインスタンスに接続し、そのインスタンスを展開します。

  2. 変更するデータベースを右クリックし、[プロパティ] をクリックします。

  3. [Database Properties]ダイアログ ボックスで、[Options]ページをクリックします。

  4. [Restrict Access]オプションで、[Single]を選択します。

  5. 他のユーザーがデータベースに接続している場合は、「オープン接続」メッセージが表示されます。プロパティを変更し、他のすべての接続を閉じるには、[はい] をクリックします。

 

Transact-SQL の使用

データベースをシングル・ユーザー・モードに設定するには、次のようにします。

  1. データベース エンジンに接続します。

  2. [Standard]バーで、[New Query]をクリックします。

  3. 次の例をコピーしてクエリウィンドウに貼り付け、「実行」ボタンをクリックします。この例では、データベースを SINGLE_USER モードを使用して排他アクセスを取得します。この例では、Avamar1データベースの状態を READ_ONLY データベースへのアクセスをすべてのユーザーに返します。終了オプション WITH ROLLBACK IMMEDIATE は、最初の ALTER DATABASE 陳述。これにより、すべての未完了トランザクションがロールバックされ、Avamar1データベースへのその他の接続はすぐに切断されます。

 

SQLCopy

USE master; GO ALTER DATABASE Avamar1 SET SINGLE_USER WITH ROLLBACK IMMEDIATE; GO ALTER DATABASE Avamar1 SET READ_ONLY; GO ALTER DATABASE Avamar1 SET MULTI_USER; GO

 


リファレンス:  https://docs.microsoft.com/en-us/sql/relational-databases/databases/set-a-database-to-single-user-mode?view=sql-server-2017

これが完了したら、元の場所へのSQLデータベースのリストアを再試行します。

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for SQL
Article Properties
Article Number: 000038587
Article Type: Solution
Last Modified: 11 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.