Análisis en clúster de Isilon: IP del servicio SmartConnect

Summary: En este artículo, hay muchas referencias sobre cómo corregir la IP del servicio SmartConnect después de una actualización a OneFS 8.2.0.0.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

En el análisis en el clúster de Isilon, se informa un resultado similar a este:

SmartConnect Service IP                           FAIL
  FAIL: The following SmartConnect Service IP Address(es) could not be located on any node: 192.168.1.1
  CRITICAL: Found client(s) connected to a SmartConnect Service IP address (SSIP), this is not supported and will stop working after the upgrade to 
        OneFS 8.2.0.0. For details on why it will no longer work in OneFS 8.2 or later see LKB000078817 [OneFS 8.2: Error "403: Forbidden - Accessing OneFS web administration interface over a configured SmartConnect service IP address is forbidden"]
  CRITICAL: Immediately following the commit of the upgrade to OneFS 8.2.0.0, the SmartConnect Service IP addresses associated with subnets that have
        VLAN tagging may disappear. Shortly after the Userspace rollup patch install is started this issue should go away. Please plan accordingly for
        there to be a disruption to new connection requests at this stage in the OneFS upgrade. For more details on this issue please review LKB000168627
        [{ISILON} Smartconnect Service IP Address (SSIP) goes missing on all configured VLAN interfaces after committing OneFS 8.2 upgrade]
  CRITICAL: Found SC Zone Name(s) and/or SC DNS Zone Alias(es) that are configured to use a DNS short name as opposed to a fully qualified domain name, this
        is not supported and will stop working after the upgrade to OneFS 8.2.0.0. For details on why it will no longer work in OneFS 8.2 or later see 
        LKB000173410 [OneFS distributed file system 8.2: If using short name/Literal instead of fully qualified domain name (FQDN), Smartconnect refuses any queries]

Cause

Las siguientes direcciones IP del servicio SmartConnect no se pudieron encontrar en ningún nodo: 192.168.1.1

Las direcciones SSIP enumeradas no se pudieron encontrar en ninguno de los nodos del clúster.  Esto puede provocar la falta de disponibilidad de datos.

Para comprobar manualmente una dirección SSIP, ejecute el siguiente comando y reemplace <SSIP> por la dirección SSIP que debe buscar:
isi_for_array ifconfig | grep <SSIP>
La solución de problemas relacionados con SmartConnect debe comenzar por seguir la Guía de solución de problemas del cliente de EMC Isilon: solución de problemas de la configuración de SmartConnect

Resolution

 

Se encontraron clientes conectados a una dirección IP del servicio SmartConnect (SSIP), esto no es compatible y dejará de funcionar después de la actualización a OneFS 8.2.0.0. Para obtener detalles sobre por qué ya no funcionará en OneFS 8.2 o versiones posteriores, consulte LKB000078817 [OneFS 8.2: Error "403: Prohibido: el acceso a la interfaz de administración web de OneFS a través de una dirección IP configurada del servicio SmartConnect está prohibido".]

La dirección IP del servicio SmartConnect está diseñada solo para búsquedas de DNS; el acceso a datos de cliente y las tareas de administración no deben realizarse en las direcciones SSIP. Para obtener detalles sobre por qué ya no funcionará en OneFS 8.2 o versiones posteriores, consulte LKB000078817 [OneFS 8.2: Error "403: Prohibido: el acceso a la interfaz de administración web de OneFS a través de una dirección IP configurada del servicio SmartConnect está prohibido".]

Inmediatamente después de la confirmación de la actualización a OneFS 8.2.0.0, es posible que desaparezcan las direcciones IP del servicio SmartConnect asociadas con las subredes que tienen etiquetado VLAN. Poco después de que se inicia la instalación del parche acumulativo del espacio de usuario, este problema debería desaparecer. Planifique según corresponda para que haya una interrupción en las nuevas solicitudes de conexión en esta etapa de la actualización de OneFS. Para obtener más detalles sobre este problema, revise LKB000168627 [{ISILON} La dirección IP del servicio SmartConnect (SSIP) desaparece en todas las interfaces VLAN configuradas después de confirmar la actualización de OneFS 8.2]

Los nombres de zona SC o los alias de zona DNS SC configurados para usar un nombre corto de DNS en lugar de un nombre de dominio calificado no son compatibles y dejarán de funcionar después de la actualización a OneFS 8.2.0.0. Para obtener detalles sobre por qué ya no funcionará en OneFS 8.2 o versiones posteriores, consulte LKB000173410 [Sistema de archivos distribuidos de OneFS 8.2: Si utiliza un nombre corto/literal en lugar del nombre de dominio calificado (FQDN), SmartConnect rechaza cualquier consulta]

Revise el siguiente artículo de la base de conocimientos para obtener más detalles sobre este problema: Si OneFS 8.2 utiliza (nombre corto/literal) en lugar de FQDN, SmartConnect rechaza cualquier consulta

Additional Information

Para ejecutar solo la comprobación de IP del servicio SmartConnect y recopilar detalles adicionales, ejecute IOCA con los argumentos adicionales: -e --run=checkSmartConnect

A continuación se presenta un ejemplo:
# perl /usr/libexec/isilon/ioca/IOCA --run=checkSmartConnect -e
Isilon On-Cluster Analysis                        0.1250
Live Cluster Analysis                             Wed Jul 10 17:22:56 2019
Cluster Name                                      Isilon
Cluster GUID                                      0000000000000000000000000000000000000
Node Count                                        3
Current OneFS Version                             8.2.0.0
SmartConnect Service IP                           FAIL
  CRITICAL: Found SC Zone Name(s) and/or SC DNS Zone Alias(es) that are configured to use a DNS short name as opposed to a fully qualified domain
        name, this is not supported and will stop working after the upgrade to OneFS 8.2.0.0. For details on why it will no longer work in OneFS 8.2
        or later see KB 534584 [https://support.emc.com/kb/534586 - OneFS 8.2 if using (short name/Literal) instead of FQDN smartconnect refuses any queries]

  ==============================
  Clients Connected to SSIPs
  ==============================
    LNN Local Address                  Remote Address
  ----- ------------------------------ ------------------------------

  ==============================
  SmartConnect Short Names
  ==============================
  Pool: groupnet0.subnet0.pool0, DNS Short Names: Isilon

  ==============================
  SmartConnect Service IP Locations
  ==============================
  SSIP                 LNN   Network Interface
  -------------------- ----- ----------
  192.168.1.1          1     lagg1

 

Affected Products

Isilon

Products

Isilon
Article Properties
Article Number: 000049446
Article Type: Solution
Last Modified: 01 Apr 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.