Unity Call-Home dispatch to CLM via SMTP

Summary: Troubleshooting of Unity call-home dispatch to CLM via Customer SMTP

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Unity call-home configured via Customer SMTP server by  svc_connectemc
Alerts and test messages not arrived to CLM portal 
https://clm-reporting-prd.cfcp.isus.emc.com/clm-reporting/#/sn/connecthome

Cause

Messages flow diagram:

kA23a000000L6UaCAK_1_0
E-Mail to emailalert@emc.com dropped in Customer SMTP gateways

Resolution

- check emailalert configuration

06:32:16 service@A1-UNITY-380 spa:~/user# svc_connectemc -g
INFO [spa]: SMTP Host: 10.100.110.24
INFO [spa]: SENDER EMAIL: eli.brank@customer.com
INFO [spa]: EMC Destination Email: emailalert@emc.com
06:32:32 service@A1-UNITY-380 spa:~/user# 


if configuration (none) - should be corrected
INFO [spa]: SENDER EMAIL: (none)@emc.com   <--  wrong configuration

06:31:23 service@A1-UNITY-380 spa:~/user# svc_connectemc -m eli.brank@customer.com
INFO [spa]: Verifying peer connectivity ...
INFO [spa]: Setting sender email address to eli.brank@
customer.com
06:32:16 service@A1-UNITY-380 spa:~/user#


- send test message
06:32:41 service@A1-UNITY-380 spa:~/user# svc_connectemc -t
INFO [spa]: Test Dialhome request sent
06:32:45 service@A1-UNITY-380 spa:~/user#


- collect fresh LOGs (SP_Collect) from Unity
open tar archive  Unity_380_service_data_CKM00202500XXX_2020-09-16_06_38_34\spa.service_dc\spa.service_dc\spa\opt\connectemc\logs
review end of file  ConnectEMCEmail.log

[2020-09-16 06:33:18] Email session details...
[2020-09-16 06:33:18] Encrypted file[1]=/opt/connectemc/poll/RSC_CKM00202500XXX_091620_063303711.cec. Size=3304
[2020-09-16 06:33:18] To: emailalert@emc.com
[2020-09-16 06:33:18] Email server: 10.100.110.24
[2020-09-16 06:33:18] To: emailalert@emc.com
[2020-09-16 06:33:18] Subject: connectemc mail
[2020-09-16 06:33:18] Attaching /opt/connectemc/poll/RSC_CKM00202500XXX_091620_063303711.cec
[2020-09-16 06:33:18] Email OK /opt/connectemc/poll/RSC_CKM00202500XXX_091620_063303711.xml 
[2020-09-16 06:33:18] Email sent to mail server successfully
2020-09-16T06:33:19  217     Info       EMAAPI3.1.0-1               
 


- check external SMTP mailer log
wrong SMTP mailer configuration:

2020-09-16 09:33:18.630 [162354] H=(VM-MAIL.customer.com) [10.1.110.224]:40882 I=[10.61.18.104]:5100 F=<eli.brank@customer.com> rejected RCPT <emailalert@emc.com>: Not allowed sender eli.brank@customer.com

2020-09-16 16:01:22.429 [406448] H=(VM-MAIL.customer.com) [10.1.110.224]:46830 I=[10.61.18.104]:5100 F=<emailalert@emc.com> rejected RCPT <emailalert@emc.com>: Not allowed sender emailalert@emc.com

correct configuration:
kA23a000000L6UaCAK_2_0

- finally should be

kA23a000000L6UaCAK_2_1

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family
Article Properties
Article Number: 000082180
Article Type: Solution
Last Modified: 20 Nov 2020
Version:  2
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