Upgrade IDPA vCenter selže s chybou „vCSACliInstallLogger - ERROR - vCenter Server Data Export failed“

Summary: Tento článek znalostní databáze vás provede selháním upgradu vCenter způsobeným chybou exportu databáze vCenter. Příčinou může být poškození databáze vCenter.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



V rozhraní ACM si můžete všimnout, že se nástroj vCenter zobrazí jako Failed.

V protokolu vcsaclientinstaller upgradu vCenter, který se nachází v adresáři „/data01/tmp/patch/logs/VCSA“, se zobrazí následující chyby:


Progress: 42% Exporting VMware vCenter Server Database data...
2020-03-26 03:41:00,145 - vCSACliInstallLogger - ERROR - vCenter Server Data Export failed.
2020-03-26 03:41:00,145 - vCSACliInstallLogger - ERROR - Upgrade failed:
Status: ERROR
Progress: 42% Exporting VMware vCenter Server Database data...
Error:
Problem Id: None
Component key: upgrade_framework
Detail:
Error while exporting source SET tables: pg_dump: Error message from server: ERROR:  invalid page in block 9 of relation base/16384/25164

Resolution: Read the log files and address the issues found in your source SET tables.
2020-03-26 03:41:00,145 - vCSACliInstallLogger - INFO - See /data01/tmp/patch/logs/vclogs/monitor-firstboot-progress-oczvL_.json file on local machine or /var/log/vmware/upgrade/export.json file on remote machine for details.



Na serveru vCenter lze navíc ověřit protokoly upgradu v umístění „/var/log/vmware/upgrade“, které mohou obsahovat následující chybovou zprávu:

VMware License Service data...
2020-03-26 17:09:01,732 - vCSACliInstallLogger - INFO - vCenter Server Data Export: Progress: 42% Exporting VMware vCenter Server Database data...
2020-03-26 17:09:12,296 - vCSACliInstallLogger - ERROR - vCenter Server Data Export failed.
2020-03-26 17:09:12,296 - vCSACliInstallLogger - ERROR - Upgrade failed:
Status: ERROR
Progress: 42% Exporting VMware vCenter Server Database data...
Error:
Problem Id: None
Component key: upgrade_framework
Detail:
Error while exporting source SET tables: pg_dump: Error message from server: ERROR:  invalid page in block 9 of relation base/16384/25164

Resolution: Read the log files and address the issues found in your source SET tables.
2020-03-26 17:09:12,296 - vCSACliInstallLogger - INFO - See /data01/tmp/patch/logs/vclogs/monitor-firstboot-progress-tmcn2I.json file on local machine or /var/log/vmware/upgrade/export.json file on remote machine for details.
2020-03-26 17:09:12,305 - vCSACliInstallLogger - INFO - Gathering VC support log bundle. This can take a few minutes.
2020-03-26 17:09:12,583 - vCSACliInstallLogger - INFO - Uninstalling vmware-upgrade-requirements-* on 192.168.100.99.
2020-03-26 17:09:13,881 - vCSACliInstallLogger - ERROR - (u'Failed to uninstall %(rpm)s on %(host)s: %(error)s', {'host': u'192.168.100.99', 'rpm': u'vmware-upgrade-requirements-*', 'error': CommandError(u"Failed to run and wait for command in guest with error 'Command '/bin/rpm' exited with non-zero status 1'",)})



Soubor postgres.log v systému vCenter obsahuje následující chybovou zprávu: 

816 UTC 5e7ce0cc.7647 24294965  LOG: automatic analyze of table "VCDB.vc.vpx_event_arg" system usage: CPU 0.02s/1.53u sec elapsed 6.15 sec
2020-03-26 17:08:19.502 UTC 5e7ce180.2530 24295002  LOG: automatic analyze of table "VCDB.vc.vpx_event" system usage: CPU 0.00s/2.40u sec elapsed 2.79 sec
2020-03-26 17:08:58.326 UTC 5e7c377f.3892 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:08:58.326 UTC 5e7c3796.3a7b 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:08:58.327 UTC 5e7c3796.3a81 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:09:09.530 UTC 5e7ce1b3.3c67 0 VCDB postgres ERROR: invalid page in block 9 of relation base/16384/25164
2020-03-26 17:09:09.530 UTC 5e7ce1b3.3c67 0 VCDB postgres STATEMENT: COPY vc.vpx_topn_past_month (counter_id, sample_time, integral_value) TO stdout;
SET zero_damaged_pages = on; select * from <corrupted table>; SET zero_damaged_pages = off;

VCDB=# select counter_id from vpx_topn_past_month;
ERROR: invalid page in block 9 of relation base/16384/25164

Cause

Selhání upgradu vCenter během úlohy exportu databáze způsobilo poškození databáze vCenter Postgres. 

Resolution

Krok 1: Přihlaste se do uživatelského rozhraní IDPA vCenter.

Krok 2: Vytvořte klon virtuálního počítače vCenter.
  • Pravým tlačítkem myši klikněte na položku VCSA VM --> Clone to Virtual Machine. 
  • Zvolte název klonu a další podrobnosti a klikněte na tlačítko OK. 

Krok 3: V uživatelském rozhraní ACM proveďte rollback virtuálního počítače vCenter. 
  • Klikněte na zaškrtávací políčko Troubleshooting Options. U položky vCenter Upgrade klikněte na možnost Rollback.  

Krok 4: Připojte se přes SSH k virtuálnímu počítači vCenter a zastavte službu vpxd.
  • service-control --stop vpxd

Krok 5: Přihlaste se do databáze vCenter Postgres.
  • /opt/vmware/vpostgres/current/bin/psql -d VCDB -U postgres
Krok 6: V databázi vCenter Postgres spusťte následující dotazy/příkazy:
  • SET zero_damaged_pages = on;
  • VACUUM FULL ANALYSE VERBOSE;
  • REINDEX table vpx_topn_past_month;
  • select * from vpx_topn_past_month;
  • SET zero_damaged_pages = off;
Krok 7: Přejděte do uživatelského rozhraní ACM, u položky vCenter Upgrade klikněte na možnost Retry a sledujte proces. 


    Additional Information

    Pokud problém přetrvává i po provedení výše uvedených kroků, obraťte se na podporu VMware. 

    Affected Products

    Integrated Data Protection Appliance Family

    Products

    PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, PowerProtect Data Protection Hardware , Integrated Data Protection Appliance Software ...
    Article Properties
    Article Number: 000173289
    Article Type: Solution
    Last Modified: 27 May 2025
    Version:  3
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.