Det går inte att genomföra uppgraderingen av IDPA vCenter och följande felmeddelande visas: ”vCSACliInstallLogger - ERROR - vCenter Server Data Export failed”
Summary: I den här KB-artikeln beskrivs ett vCenter-uppgraderingsfel som orsakas av att det inte går att genomföra vCenter-databasexport. Det kan bero på att vCenter-databasen är skadad.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
På ACM kan du märka att vCenter inte fungerar.
I katalogen ”/data01/tmp/patch/logs/VCSA” med vCenter-uppgraderingsloggar visas följande i vcsaclientinstaller-loggen:
Progress: 42% Exporting VMware vCenter Server Database data...
2020-03-26 03:41:00,145 - vCSACliInstallLogger - ERROR - vCenter Server Data Export failed.
2020-03-26 03:41:00,145 - vCSACliInstallLogger - ERROR - Upgrade failed:
Status: ERROR
Progress: 42% Exporting VMware vCenter Server Database data...
Error:
Problem Id: None
Component key: upgrade_framework
Detail:
Error while exporting source SET tables: pg_dump: Error message from server: ERROR: invalid page in block 9 of relation base/16384/25164
Resolution: Read the log files and address the issues found in your source SET tables.
2020-03-26 03:41:00,145 - vCSACliInstallLogger - INFO - See /data01/tmp/patch/logs/vclogs/monitor-firstboot-progress-oczvL_.json file on local machine or /var/log/vmware/upgrade/export.json file on remote machine for details.
Dessutom kan du även kontrollera uppgraderingsloggar på vCenter-servern i ”/var/log/vmware/upgrade” och följande felmeddelande kan visas:
VMware License Service data...
2020-03-26 17:09:01,732 - vCSACliInstallLogger - INFO - vCenter Server Data Export: Progress: 42% Exporting VMware vCenter Server Database data...
2020-03-26 17:09:12,296 - vCSACliInstallLogger - ERROR - vCenter Server Data Export failed.
2020-03-26 17:09:12,296 - vCSACliInstallLogger - ERROR - Upgrade failed:
Status: ERROR
Progress: 42% Exporting VMware vCenter Server Database data...
Error:
Problem Id: None
Component key: upgrade_framework
Detail:
Error while exporting source SET tables: pg_dump: Error message from server: ERROR: invalid page in block 9 of relation base/16384/25164
Resolution: Read the log files and address the issues found in your source SET tables.
2020-03-26 17:09:12,296 - vCSACliInstallLogger - INFO - See /data01/tmp/patch/logs/vclogs/monitor-firstboot-progress-tmcn2I.json file on local machine or /var/log/vmware/upgrade/export.json file on remote machine for details.
2020-03-26 17:09:12,305 - vCSACliInstallLogger - INFO - Gathering VC support log bundle. This can take a few minutes.
2020-03-26 17:09:12,583 - vCSACliInstallLogger - INFO - Uninstalling vmware-upgrade-requirements-* on 192.168.100.99.
2020-03-26 17:09:13,881 - vCSACliInstallLogger - ERROR - (u'Failed to uninstall %(rpm)s on %(host)s: %(error)s', {'host': u'192.168.100.99', 'rpm': u'vmware-upgrade-requirements-*', 'error': CommandError(u"Failed to run and wait for command in guest with error 'Command '/bin/rpm' exited with non-zero status 1'",)})
I postgres.log på vCenter visas följande felmeddelande:
816 UTC 5e7ce0cc.7647 24294965 LOG: automatic analyze of table "VCDB.vc.vpx_event_arg" system usage: CPU 0.02s/1.53u sec elapsed 6.15 sec
2020-03-26 17:08:19.502 UTC 5e7ce180.2530 24295002 LOG: automatic analyze of table "VCDB.vc.vpx_event" system usage: CPU 0.00s/2.40u sec elapsed 2.79 sec
2020-03-26 17:08:58.326 UTC 5e7c377f.3892 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:08:58.326 UTC 5e7c3796.3a7b 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:08:58.327 UTC 5e7c3796.3a81 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:09:09.530 UTC 5e7ce1b3.3c67 0 VCDB postgres ERROR: invalid page in block 9 of relation base/16384/25164
2020-03-26 17:09:09.530 UTC 5e7ce1b3.3c67 0 VCDB postgres STATEMENT: COPY vc.vpx_topn_past_month (counter_id, sample_time, integral_value) TO stdout;
SET zero_damaged_pages = on; select * from <corrupted table>; SET zero_damaged_pages = off;
VCDB=# select counter_id from vpx_topn_past_month;
ERROR: invalid page in block 9 of relation base/16384/25164
Cause
Ett fel i vCenter Postgres-databasen gjorde att det inte gick att genomföra vCenter-uppgraderingen under databasexporten.
Resolution
Steg 1: Logga in på IDPA vCenter-användargränssnittet.
Steg 2: Gör en klon av den virtuella vCenter-datorn.
Steg 3: Gör en återställning av den virtuella vCenter-datorn i ACM-användargränssnittet.
Steg 4: SSH-anslut till den virtuella vCenter-datorn och stoppa vpxd-tjänsten.
Steg 5: Logga in på vCenter Postgres-databasen.
Steg 2: Gör en klon av den virtuella vCenter-datorn.
- Högerklicka på VCSA VM --> Clone to Virtual Machine.
- Välj namnet på klonen och annan information och klicka på OK.
Steg 3: Gör en återställning av den virtuella vCenter-datorn i ACM-användargränssnittet.
- Markera kryssrutan Troubleshooting Options. Klicka på Rollback for vCenter Upgrade.
Steg 4: SSH-anslut till den virtuella vCenter-datorn och stoppa vpxd-tjänsten.
- service-control --stop vpxd
Steg 5: Logga in på vCenter Postgres-databasen.
- /opt/vmware/vpostgres/current/bin/psql -d VCDB -U postgres
- SET zero_damaged_pages = on;
- VACUUM FULL ANALYSE VERBOSE;
- REINDEX table vpx_topn_past_month;
- select * from vpx_topn_past_month;
- SET zero_damaged_pages = off;
Additional Information
Kontakta VMware-support om problemet kvarstår efter att du har gått igenom stegen ovan.
Affected Products
Integrated Data Protection Appliance FamilyProducts
PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, PowerProtect Data Protection Hardware
, Integrated Data Protection Appliance Software
...
Article Properties
Article Number: 000173289
Article Type: Solution
Last Modified: 27 May 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.