ECS: 'Validate BMC availability' failed: Invalid BMC configuration due to IPMI over LAN is disabled also ssh to BMC IP address connection refused
Summary: - [ERROR] 'Validate BMC availability' failed: Invalid BMC configuration - When all configuration is correct, the user/password is correct and the BMC IP address is pingable. - IPMI tool works locally on the server, but when you try to use it over LAN/IP it return an error. - Also when trying to ssh the BMC IP address (192.168.219.10x) it refuses the connection. ...
Symptoms
Issue # 1 When doing a compliance or health check it returns "[ERROR] 'Validate BMC availability' failed: Invalid BMC configuration on some/all nodes."
On node with IP 169.254.1.1 and FQDN xxxxx-node1.yyyyy.com, Can't connect to BMC IP 192.168.219.101 On node with IP 169.254.1.3 and FQDN xxxxx-node3.yyyyy.com, Can't connect to BMC IP 192.168.219.103 On node with IP 169.254.1.4 and FQDN xxxxx-node4.yyyyy.com, Can't connect to BMC IP 192.168.219.104 On node with IP 169.254.1.5 and FQDN xxxxx-node5.yyyyy.com, Can't connect to BMC IP 192.168.219.105
When using IPMI tool locally it works fine, but when using IPMI over LAN for the same node it does not work.
admin@xxxxx-node1:~> sudo ipmitool chassis power status
Chassis Power is on
admin@xxxxx-node1:~> ipmitool -I lanplus -H 192.168.219.101 -U root -P passwd power status
Error: Unable to establish IPMI v2 / RMCP+ session
Issue # 2 Also, when trying to ssh the BMC IP address it refuses the connection.
admin@xxxxx-node1~> ssh root@192.168.219.101
ssh: connect to host 192.168.219.101 port 22: Connection refused
Cause
Issue # 1: IPMI over LAN is disabled.
Issue # 2: SSH is disabled.
Resolution
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To fix this, you must log in to the BMC UI of the issued nodes. You can do so by following KB 000019917: ECS: How to connect to BMC/iDRAC console and VDC UI via Secure Remote Services
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After a successful login to the BMC UI, select Configuration> Security Settings.
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As in the figure IPMI over LAN/SSH Disabled, You must check the boxes and click Save to Enable.

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For Issue # 1: After enabling IPMI over LAN, run "
service-console run Health_Check --specific-check Validate BMC availability" to confirm if the validation issue is fixed it should PASS as below.Service console version: 8.3.0.0-22532.3ce6e27b27 Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log ================================================================================ Health Check 20240617 15:58:19.631: Execute Specific Health Checks 20240617 15:58:19.633: | Validate BMC availability 20240617 15:58:26.973: | | PASS (7 sec) 20240617 15:58:26.974: | PASS (7 sec) ================================================================================ Status: PASS Time Elapsed: 23 sec Debug log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/dbg_robot.log HTML log: /opt/emc/caspian/service-console/log/20240617_155807_run_Health_Check/log.html ==================================================================
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For issue # 2: After enabling SSH, ssh to the BMC IP address and it should connect as below.
admin@xxxxx-node1:~> ssh root@192.168.219.101 Warning: Permanently added '192.168.219.101' (RSA) to the list of known hosts. Password: >> SMASH-CLP Console v1.09 << ->